[Numpy-discussion] numpy.stack -- which function, if any, deserves the name?

Stephan Hoyer shoyer at gmail.com
Mon Mar 16 14:27:29 EDT 2015

On Mon, Mar 16, 2015 at 1:50 AM, Stefan Otte <stefan.otte at gmail.com> wrote:

> Summarizing, my proposal is mostly concerned how to create block
> arrays from given arrays. I don't care about the name "stack". I just
> used "stack" because it replaced hstack/vstack for me. Maybe "bstack"
> for block stack, or "barray" for block array?

Stefan -- thanks for sharing your perspective!

In conclusion, it sounds like we could safely use "stack" for my PR
(proposal 2), and use another name (perhaps "block", "barray" or
"block_array") for your proposal. I'm also not opposed to using a new verb
for my PR (the stacking alternative to "concatenate"), but I haven't come
up with any more descriptive alternatives.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20150316/390db14d/attachment.html>

More information about the NumPy-Discussion mailing list