[Numpy-discussion] Is this a known error in Ipython with numpy?

Elliot Hallmark Permafacture at gmail.com
Wed Apr 27 19:48:13 EDT 2016


Hello,

I haven't worked hard yet to create a minimal runnable (reproduce-able)
example but I wanted to check if this sounds familiar to anyone.

I have a pretty involved program that resizes arrays in place with
arr.resize.  When I run it with python it completes and gives the expected
result.  When I run it in Ipython, I get the following error:

```
    ---> 43         self._buffer.resize((count,)+self._dim)
         44
         45

    ValueError: cannot resize an array that references or is referenced
    by another array in this way.  Use the resize function
```

It was consistently doing this on the same array, after resizing two others
before hand, even after rebooting.  But trying to track it down it goes
away even if I undo everything I did to try and track it down.

Does this sound familiar?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20160427/6f2c1ebb/attachment.html>


More information about the NumPy-Discussion mailing list