[Numpy-discussion] Added atleast_nd, request for clarification/cleanup of atleast_3d

Eric Firing efiring at hawaii.edu
Wed Jul 6 14:57:48 EDT 2016

On 2016/07/06 8:25 AM, Benjamin Root wrote:
> I wouldn't have the keyword be "where", as that collides with the notion
> of "where" elsewhere in numpy.

Agreed.  Maybe "side"?

(I find atleast_1d and atleast_2d to be very helpful for handling 
inputs, as Ben noted; I'm skeptical as to the value of atleast_3d and 


More information about the NumPy-Discussion mailing list