[Numpy-discussion] Adding out to bincount

Jaime Fernández del Río jaime.frio at gmail.com
Thu Jul 13 07:34:50 EDT 2017


There is an ongoing discussion on #9397
<https://github.com/numpy/numpy/issues/9397> about adding an out= keyword
argument to np.bincount().

Presently the design seems headed toward:

   - the new counts will be added to the contents of out, perhaps we need a
   better name than out, suggestions welcome
   - if minlength is specified and it doesn't match exactly the size of out,
   an error will be raised,
   - if any of the input indices is outside the bounds of the out array, an
   error will be raised, and
   - if the out array is not of the exact right type, i.e. np.double if
   weights are specified, np.intp if not, an error will be raised.

If you have an opinion about this functionality please head over there and
have your say.

Jaime

-- 
(\__/)
( O.o)
( > <) Este es Conejo. Copia a Conejo en tu firma y ayúdale en sus planes
de dominación mundial.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20170713/bc9b517d/attachment-0001.html>


More information about the NumPy-Discussion mailing list