[Numpy-discussion] with np.testing.assert_raises still requires nose.

Andrew Nelson andyfaff at gmail.com
Tue Jan 23 05:04:06 EST 2018


Dear np list,
from a recent scipy PR (https://github.com/scipy/scipy/pull/8322) it
appears that the `np.testing.assert_raises` context manager still requires
nose to be installed:
https://ci.appveyor.com/project/scipy/scipy/build/1.0.1550/job/s5nq8xqd0n72feqf

The appveyor test is using numpy-1.14.0

This doesn't seem to be an issue on our travis tests, only the windows
tests. Is this a bug?

-- 
_____________________________________
Dr. Andrew Nelson


_____________________________________
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20180123/ec7cc8fc/attachment.html>


More information about the NumPy-Discussion mailing list