[Numpy-discussion] Unsupporting python3.5

Charles R Harris charlesr.harris at gmail.com
Thu Oct 10 12:34:55 EDT 2019

On Thu, Oct 10, 2019 at 9:31 AM Matti Picus <matti.picus at gmail.com> wrote:

> According to NEP 29, numpy 1.18 will be released after Sept 2019, which as
> I understand it is the cutoff for Python 3.5. In PR 14673 I proposed
> removing it from the test matrix and also removing some shims in the code
> to support it - meaning that in order to use Numpy 1.18+ you will need to
> use Python 3.5+. Is this the intention of the NEP or is the intention only
> that we no longer test it and no longer supply wheels? If the latter, at
> what point do we remove support code for unsupported versions?
> Note the cost of this code is negligible, it is more a question of what is
> the correct/desired approach.

I think we can support 3.5 as long as we please, the question is how long
we *want* to support it. I don't plan to release 1.18 wheels for 3.5, but
I'm concerned about making 1.18 outright incompatible with 3.5. I would
like to see the random interface settle before we do that. So my preference
would be to drop 3.5 in 1.19 with a future warning in the 1.18 release
notes. Alternatively, we could backport all the random changes to 1.17, but
I would rather not do that.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20191010/7faea5f2/attachment.html>

More information about the NumPy-Discussion mailing list