[Numpy-discussion] numpy.linalg interference with matplot.lib

Frederix96 frederix.noel at gmail.com
Mon Jan 11 05:51:14 EST 2021

Dear numpy community,

I am having an issue with numpy.linalg where a matrix inversion of a 
complex matrix using numpy.linalg.inv results in containing nan values 
when a plot of any kind was performed beforehand by matplotlib. For the 
specific details on the problem and what I have tried already see the 
stackoverflow post I started a month ago:


I know that this problem has to do with some specifics of the maschine I 
am using, as it does not happen on other maschines I tried. However it 
still appears after rebuilding my entire python enviroment. Hence I ran 
out of options appart from setting up my whole PC from scratch again, 
which I would rather not do.

Is some problem like this known in the community?

Has anyone an idea at which other specifications of my system it might 
be worth taking a look at?

Thanks a lot in advance!

Best regards,


More information about the NumPy-Discussion mailing list