[Numpy-discussion] guide for downstream package authors & setting version constraints

Ralf Gommers ralf.gommers at gmail.com
Mon Mar 1 04:53:11 EST 2021


Hi all,

We now have a guide for downstream package authors, talking about API and
ABI stability, NumPy versioning, testing against NumPy master, and how to
add build time and runtime dependencies for numpy:
https://numpy.org/devdocs/user/depending_on_numpy.html

Especially the version constraints and setting upper bounds for
install_requires correctly is important - almost no packages do this
correctly (or at all really). If your package depends on NumPy and you deal
with packaging it, please check it out!

And for even more practical details on release process steps for a
downstream package, see
http://scipy.github.io/devdocs/dev/core-dev/index.html#updating-upper-bounds-of-dependencies

Cheers,
Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.python.org/pipermail/numpy-discussion/attachments/20210301/db66f603/attachment.html>


More information about the NumPy-Discussion mailing list