<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:'times new roman', 'new york', times, serif;font-size:12pt"><div>Thank you very much! It resolved the problem. I have successfully installed the numpy for Python 2.7</div><div style="font-family:times new roman, new york, times, serif;font-size:12pt"><br><div style="font-family:times new roman, new york, times, serif;font-size:12pt"><font size="2" face="Tahoma"><hr size="1"><b><span style="font-weight: bold;">From:</span></b> Shao Hong <shaohong86@gmail.com><br><b><span style="font-weight: bold;">To:</span></b> Discussion of Numerical Python <numpy-discussion@scipy.org><br><b><span style="font-weight: bold;">Sent:</span></b> Wed, February 23, 2011 3:27:16 PM<br><b><span style="font-weight: bold;">Subject:</span></b> Re: [Numpy-discussion] Problems with installation (wrong Python version)<br></font><br><meta
 http-equiv="x-dns-prefetch-control" content="off">Hi! I think you should download the 2.7 pack ( <a rel="nofollow" target="_blank" href="http://sourceforge.net/projects/numpy/files/NumPy/1.5.1/numpy-1.5.1-win32-superpack-python2.7.exe/download">http://sourceforge.net/projects/numpy/files/NumPy/1.5.1/numpy-1.5.1-win32-superpack-python2.7.exe/download</a> ) and it might detect your python 2.7 instead. <br clear="all">

<div><br></div><div><br></div>Shao Hong<br><br>
<br><br><div class="gmail_quote">On Wed, Feb 23, 2011 at 10:22 PM, Dumka Dumka <span dir="ltr"><<a rel="nofollow" ymailto="mailto:dumka.dumka@yahoo.com" target="_blank" href="mailto:dumka.dumka@yahoo.com">dumka.dumka@yahoo.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

<div><div style="font-size:12pt;"><div style="color:black;font-size:12pt;">Dear numpy Community,</div>

<div style="color:black;font-size:12pt;"><br></div><div style="color:black;font-size:12pt;">

I try to install numpy on my Windows 7. I take the code from here: </div><div style="color:black;font-size:12pt;"><a rel="nofollow" target="_blank" href="http://sourceforge.net/projects/numpy/files/NumPy/">http://sourceforge.net/projects/numpy/files/NumPy/</a>  (I click on "Download numpy-1.5.1-win32-superpack-python2.6.exe (5.4 MB)").</div>

<div style="color:black;font-size:12pt;"><br></div><div style="color:black;font-size:12pt;">

After I start the installation, the installer tells me: Python version 2.6 (Found in registry). I also see the link to the "C:\Python26" directory in the installation window.</div><div style="color:black;font-size:12pt;">

<br></div><div style="color:black;font-size:12pt;">However, I want to use Python2.7 (I had it on my computer together with the Python 2.6). So, I deleted the "C:\Python26" directory an set a new value to the "Path" environment variable to make a link to the newer version of the Python (version 2.7). I also restarted the computer.</div>

<div style="color:black;font-size:12pt;"><br></div><div style="color:black;font-size:12pt;">

However, it does not help. When I try to run the numpy installer again I see the same: Python version 2.6 (Found in registry). I cannot understand where the installer find the link to the old version. If I just continue the installation, it fails (and it started to fail after I deleted the "C:\Python26" directory). So, to summarize, numpy installer "thinks" that I have Python 2.6 (and I don't) and then it fails because it is wrong.</div>

<div style="color:black;font-size:12pt;"><br></div><div style="color:black;font-size:12pt;">

How can I force the numpy installer to use Python 2.7? Can I?</div><div style="color:black;font-size:12pt;"><br></div><div style="color:black;font-size:12pt;">

Thank you in advance for any help,</div><div style="color:black;font-size:12pt;">Dumka</div><div style="color:black;font-size:12pt;">

</div>


</div><br>

      </div><br>_______________________________________________<br>
NumPy-Discussion mailing list<br>
<a rel="nofollow" ymailto="mailto:NumPy-Discussion@scipy.org" target="_blank" href="mailto:NumPy-Discussion@scipy.org">NumPy-Discussion@scipy.org</a><br>
<a rel="nofollow" target="_blank" href="http://mail.scipy.org/mailman/listinfo/numpy-discussion">http://mail.scipy.org/mailman/listinfo/numpy-discussion</a><br>
<br></blockquote></div><br>
<meta http-equiv="x-dns-prefetch-control" content="on"></div></div><div style="position:fixed"></div>


</div><br>

      </body></html>