<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 10pt;
font-family:Tahoma
}
--></style></head>
<body class='hmmessage'><div dir='ltr'>
Hi,<div>I run : </div><div>python setup.py build</div><div><br></div><div>and got: </div><div><br></div><div><div>building library "npymath" sources</div><div>customize GnuFCompiler</div><div>Could not locate executable g77</div><div>Could not locate executable f77</div><div>customize IntelFCompiler</div><div>Could not locate executable ifort</div><div>Could not locate executable ifc</div><div>customize LaheyFCompiler</div><div>Could not locate executable lf95</div><div>customize PGroupFCompiler</div><div>Could not locate executable pgf90</div><div>Could not locate executable pgf77</div><div>customize AbsoftFCompiler</div><div>Could not locate executable f90</div><div>customize NAGFCompiler</div><div>Found executable /usr/bin/f95</div><div>customize VastFCompiler</div><div>customize CompaqFCompiler</div><div>Could not locate executable fort</div><div>customize IntelItaniumFCompiler</div><div>Could not locate executable efort</div><div>Could not locate executable efc</div><div>customize IntelEM64TFCompiler</div><div>customize Gnu95FCompiler</div><div>Found executable /usr/bin/gfortran</div><div>customize Gnu95FCompiler</div><div>customize Gnu95FCompiler using config</div><div>C compiler: gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC</div></div><div>.........</div><div><br></div><div><div>building extension "numpy.random.mtrand" sources</div><div>C compiler: gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC</div><div><br></div><div>compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/include -I/python272/include/python2.7 -c'</div><div>gcc: _configtest.c</div><div>gcc -pthread _configtest.o -o _configtest</div><div>_configtest</div><div><b>failure</b>.</div><div><br></div><div>then : </div><div><br></div><div>python setup.py install --prefix=/mypath/numpy</div><div><br></div><div>I got: </div><div><br></div><div><div>Running from numpy source directory.non-existing path in 'numpy/distutils': 'site.cfg'</div><div>F2PY Version 2</div><div>blas_opt_info:</div><div>blas_mkl_info:</div><div>  libraries mkl,vml,guide not found in /mypath/python272/lib</div><div>  libraries mkl,vml,guide not found in /usr/local/lib64</div><div>  libraries mkl,vml,guide not found in /usr/local/lib</div><div>  libraries mkl,vml,guide not found in /usr/lib64</div><div>  libraries mkl,vml,guide not found in /usr/lib</div><div>  NOT AVAILABLE</div><div><br></div><div>atlas_blas_threads_info:</div><div>Setting PTATLAS=ATLAS</div><div>  libraries ptf77blas,ptcblas,atlas not found in /
mypath/python272/lib</div><div>  libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib64</div><div>  libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib</div><div>  libraries ptf77blas,ptcblas,atlas not found in /usr/lib64/sse2</div><div>  libraries ptf77blas,ptcblas,atlas not found in /usr/lib64</div><div>  libraries ptf77blas,ptcblas,atlas not found in /usr/lib/sse2</div><div>  libraries ptf77blas,ptcblas,atlas not found in /usr/lib</div><div>  NOT AVAILABLE</div><div><br></div><div>atlas_blas_info:</div><div>  libraries f77blas,cblas,atlas not found in /<span style="font-size: 10pt; ">mypath</span><span style="font-size: 10pt; ">/python272/lib</span></div><div>  libraries f77blas,cblas,atlas not found in /usr/local/lib64</div><div>  libraries f77blas,cblas,atlas not found in /usr/local/lib</div><div>  libraries f77blas,cblas,atlas not found in /usr/lib64/sse2</div><div>  libraries f77blas,cblas,atlas not found in /usr/lib64</div><div>  libraries f77blas,cblas,atlas not found in /usr/lib/sse2</div><div>  libraries f77blas,cblas,atlas not found in /usr/lib</div><div>  NOT AVAILABLE</div></div><div><br></div><div><div>UserWarning:</div><div>    Lapack (http://www.netlib.org/lapack/) libraries not found.</div><div>    Directories to search for the libraries can be specified in the</div><div>    numpy/distutils/site.cfg file (section [lapack]) or by setting</div><div>    the LAPACK environment variable.</div><div>  warnings.warn(LapackNotFoundError.__doc__)</div><div>lapack_src_info:</div><div>  NOT AVAILABLE</div></div><div><br></div><div><br></div><div><div>Lapack (http://www.netlib.org/lapack/) sources not found.</div><div>    Directories to search for the sources can be specified in the</div><div>    numpy/distutils/site.cfg file (section [lapack_src]) or by setting</div><div>    the LAPACK_SRC environment variable.</div><div>  warnings.warn(LapackSrcNotFoundError.__doc__)</div><div>  NOT AVAILABLE</div></div><div><br></div><div><div>running install</div><div>running build</div><div>running config_cc</div><div>unifing config_cc, config, build_clib, build_ext, build commands --compiler options</div><div>running config_fc</div><div>unifing config_fc, config, build_clib, build_ext, build commands --fcompiler options</div><div>running build_src</div><div>build_src</div><div>building py_modules sources</div><div>building library "npymath" sources</div><div>customize GnuFCompiler</div><div>Could not locate executable g77</div><div>Could not locate executable f77</div><div>customize IntelFCompiler</div><div>Could not locate executable ifort</div><div>Could not locate executable ifc</div><div>customize LaheyFCompiler</div><div>Could not locate executable lf95</div><div>customize PGroupFCompiler</div><div>Could not locate executable pgf90</div><div>Could not locate executable pgf77</div><div>customize AbsoftFCompiler</div><div>Could not locate executable f90</div><div>customize NAGFCompiler</div><div>Found executable /usr/bin/f95</div><div>customize VastFCompiler</div><div>customize CompaqFCompiler</div><div>Could not locate executable fort</div><div>customize IntelItaniumFCompiler</div><div>Could not locate executable efort</div><div>Could not locate executable efc</div><div>customize IntelEM64TFCompiler</div><div>customize Gnu95FCompiler</div><div>Found executable /usr/bin/gfortran</div><div>customize Gnu95FCompiler</div><div>customize Gnu95FCompiler using config</div><div>C compiler: gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC</div><div><br></div><div>compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/include -I/remote/dcnl/Ding/backup_20100716/python272/include/python2.7 -c'</div><div>gcc: _configtest.c</div><div>gcc -pthread _configtest.o -o _configtest</div><div>success!</div><div>removing: _configtest.c _configtest.o _configtest</div><div>C compiler: gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC</div></div><div><br></div><div><br></div><div>........................</div><div><br></div><div><div>compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/include -I/mypath/python272/include/python2.7 -c'</div><div>gcc: _configtest.c</div><div>gcc -pthread _configtest.o -o _configtest</div><div>_configtest</div><div>failure.</div></div><div><br></div><div>at the end:</div><div><br></div><div><div>running install_egg_info</div><div>Removing /mypath/numpy/lib/python2.7/site-packages/numpy-1.6.1-py2.7.egg-info</div><div>Writing /mypath/numpy/lib/python2.7/site-packages/numpy-1.6.1-py2.7.egg-info</div><div>running install_clib</div></div><div><br></div><div>Then </div><div><br></div><div>I got: </div><div><br></div><div><div>python</div><div>Python 2.7.2 (default, Dec 20 2011, 12:32:10)</div><div>[GCC 4.1.2 20080704 (Red Hat 4.1.2-51)] on linux2</div><div>Type "help", "copyright", "credits" or "license" for more information.</div><div><br></div><div>>>> import numpy</div><div>Traceback (most recent call last):</div><div>  File "<stdin>", line 1, in <module></div><div><b>ImportError: No module named numpy</b></div></div><div><br></div><div><br></div><div>I have updated PATH for bin and lib of numpy. </div><div><br></div><div><span style="font-size: 10pt; ">I have got </span>f2py and lib files : </div><div><br></div><div><div>add_newdocs.py   distutils          __init__.py   numarray        testing</div><div>add_newdocs.pyc  doc                __init__.pyc  oldnumeric      tests</div><div>compat           dual.py            lib           polynomial      version.py</div><div>__config__.py    dual.pyc           linalg        random          version.pyc</div><div>__config__.pyc   f2py               ma            setup.py</div><div>core             fft                matlib.py     setup.pyc</div><div>ctypeslib.py     _import_tools.py   matlib.pyc    setupscons.py</div><div>ctypeslib.pyc    _import_tools.pyc  matrixlib     setupscons.pyc</div></div><div><br></div><div><br></div><div>Any help is really appreciated. </div><div><br></div><div>thanks</div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><br><div><div id="SkyDrivePlaceholder"></div>> From: derek@astro.physik.uni-goettingen.de<br>> Date: Tue, 20 Dec 2011 20:43:53 +0100<br>> To: numpy-discussion@scipy.org<br>> Subject: Re: [Numpy-discussion] numpy1.6.1 install fortran compiler error<br>> <br>> Hi Jack,<br>> <br>> > In order to install scipy,  I am trying to install numpy 1.6.1. on GNU/linux redhat  2.6.18. <br>> > <br>> > But, I got error about fortran compiler. <br>> > <br>> > I have gfortran. I do not have f77/f90/g77/g90.<br>> > <br>> that's good!<br>> <br>> > I run :<br>> > python setup.py build --fcompiler=gfortran<br>> > <br>> > It woks well and tells me that <br>> > <br>> > customize Gnu95FCompiler<br>> > Found executable /usr/bin/gfortran<br>> > <br>> > But, i run: <br>> > <br>> > building library "npymath" sources<br>> > customize GnuFCompiler<br>> > Could not locate executable g77<br>> > Could not locate executable f77<br>> > customize IntelFCompiler<br>> > Could not locate executable ifort<br>> > Could not locate executable ifc<br>> > customize LaheyFCompiler<br>> > Could not locate executable lf95<br>> > customize PGroupFCompiler<br>> > Could not locate executable pgf90<br>> > Could not locate executable pgf77<br>> > customize AbsoftFCompiler<br>> > Could not locate executable f90<br>> > customize NAGFCompiler<br>> > Found executable /usr/bin/f95<br>> > customize Gnu95FCompiler<br>> > customize Gnu95FCompiler using config<br>> > C compiler: gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC<br>> > <br>> > Do I have to install f77/f90/g77/g90 ? <br>> > <br>> You did not send any actual error message here, so it's difficult to tell <br>> where exactly your install failed. But gfortran is preferred over f77 etc. <br>> and should in fact be automatically selected (without the '--fcompiler=gfortran'), <br>> it is apparently also found in the right place. <br>> Could you send us the last lines of output with the error itself, or possibly  <br>> everything following a line starting with "Traceback:.." ; <br>> and also the output of `gfortran -v`?<br>> <br>> Cheers,<br>>                                                      Derek<br>> <br>> _______________________________________________<br>> NumPy-Discussion mailing list<br>> NumPy-Discussion@scipy.org<br>> http://mail.scipy.org/mailman/listinfo/numpy-discussion<br></div></div>                                           </div></body>
</html>