<br><br><div class="gmail_quote">On Tue, Aug 21, 2012 at 1:59 PM, Christoph Gohlke <span dir="ltr"><<a href="mailto:cgohlke@uci.edu" target="_blank">cgohlke@uci.edu</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="im">On 8/21/2012 9:24 AM, Ondřej Čertík wrote:<br>
> Hi,<br>
><br>
> I'm pleased to announce the availability of the first beta release of<br>
> NumPy 1.7.0b1.<br>
><br>
> Sources and binary installers can be found at<br>
> <a href="https://sourceforge.net/projects/numpy/files/NumPy/1.7.0b1/" target="_blank">https://sourceforge.net/projects/numpy/files/NumPy/1.7.0b1/</a><br>
><br>
> Please test this release and report any issues on the numpy-discussion<br>
> mailing list. The following problems are known and<br>
> we'll work on fixing them before the final release:<br>
><br>
> <a href="http://projects.scipy.org/numpy/ticket/2187" target="_blank">http://projects.scipy.org/numpy/ticket/2187</a><br>
> <a href="http://projects.scipy.org/numpy/ticket/2185" target="_blank">http://projects.scipy.org/numpy/ticket/2185</a><br>
> <a href="http://projects.scipy.org/numpy/ticket/2066" target="_blank">http://projects.scipy.org/numpy/ticket/2066</a><br>
> <a href="http://projects.scipy.org/numpy/ticket/1588" target="_blank">http://projects.scipy.org/numpy/ticket/1588</a><br>
> <a href="http://projects.scipy.org/numpy/ticket/2076" target="_blank">http://projects.scipy.org/numpy/ticket/2076</a><br>
> <a href="http://projects.scipy.org/numpy/ticket/2101" target="_blank">http://projects.scipy.org/numpy/ticket/2101</a><br>
> <a href="http://projects.scipy.org/numpy/ticket/2108" target="_blank">http://projects.scipy.org/numpy/ticket/2108</a><br>
> <a href="http://projects.scipy.org/numpy/ticket/2150" target="_blank">http://projects.scipy.org/numpy/ticket/2150</a><br>
> <a href="http://projects.scipy.org/numpy/ticket/2189" target="_blank">http://projects.scipy.org/numpy/ticket/2189</a><br>
><br>
> I would like to thank Ralf for a lot of help with creating binaries<br>
> and other help for this release.<br>
><br>
> Cheers,<br>
> Ondrej<br>
><br>
><br>
<br>
</div>Hi Ondrej,<br>
<br>
will numpy 1.7.0 final support Python 3.3? The recent patch in the<br>
master branch seems to work well.<br>
<br>
I tested a win-amd64-py2.7\msvc9\MKL build of the numpy<br>
maintenance/1.7.x branch against a number of package binaries from<br>
<<a href="http://www.lfd.uci.edu/%7Egohlke/pythonlibs/" target="_blank">http://www.lfd.uci.edu/~gohlke/pythonlibs/</a>>.<br>
<br>
The test results are at<br>
<<a href="http://www.lfd.uci.edu/%7Egohlke/pythonlibs/tests/20120821-win-amd64-py2.7-numpy-MKL-1.7.0rc1.dev-28ffac7/" target="_blank">http://www.lfd.uci.edu/~gohlke/pythonlibs/tests/20120821-win-amd64-py2.7-numpy-MKL-1.7.0rc1.dev-28ffac7/</a>>.<br>
</blockquote><div><br>What version of Numpy were the test packages compiled against?<br> <br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
For comparison, the tests against numpy-MKL-1.6.2 are at<br>
<<a href="http://www.lfd.uci.edu/%7Egohlke/pythonlibs/tests/20120821-win-amd64-py2.7/" target="_blank">http://www.lfd.uci.edu/~gohlke/pythonlibs/tests/20120821-win-amd64-py2.7/</a>>.<br>
<br>
Besides some numpy 1.7.x test errors due to RuntimeWarning and<br>
DeprecationWarning, there are hundreds of "RuntimeWarning (numpy.dtype<br>
size changed, may indicate binary incompatibility)" when loading Cython<br>
extensions.<br>
<br>
There are additional test failures in scipy, statsmodels, bottleneck,<br>
skimage, vigra, and mahotas. I did not check in detail or with existing<br>
tickets (<a href="http://projects.scipy.org/" target="_blank">http://projects.scipy.org/</a> is timing out or responding with<br>
HTTP 500 status).<br>
<br>
Other packages test OK against numpy 1.7.x, e.g. PIL, PyGame,<br>
matplotlib, Pandas, tables, and numexpr.<br>
<br></blockquote><div><br>Chuck <br></div><br></div>