<br><br><div class="gmail_quote">On Sat, May 18, 2013 at 1:11 AM, Joe Piccoli <span dir="ltr"><<a href="mailto:joe13676@comcast.net" target="_blank">joe13676@comcast.net</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div link="blue" vlink="purple" lang="EN-US"><div><p class="MsoNormal">Hello,<u></u><u></u></p><p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal">I've been trying to install NumPy to run with Eclipse on Windows Vista. After installing (I thought) NumPy I was seeing:<u></u><u></u></p>
<p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal" style="text-autospace:none"><span style="font-size:10.0pt;font-family:Consolas;color:red">ImportError: Error importing numpy: you should not try to import numpy from</span><span style="font-size:10.0pt;font-family:Consolas"><u></u><u></u></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:10.0pt;font-family:Consolas;color:red">        its source directory; please exit the numpy source tree, and relaunch</span><span style="font-size:10.0pt;font-family:Consolas"><u></u><u></u></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:10.0pt;font-family:Consolas;color:red">        your python intepreter from there.</span></p></div></div></blockquote><div><br>Did you try to do this (what it says here)?<br>
<br>Josef<br><br> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div link="blue" vlink="purple" lang="EN-US"><div><p class="MsoNormal" style="text-autospace:none">
<span style="font-size:10.0pt;font-family:Consolas"><u></u><u></u></span></p><p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal">I next tried to follow the instructions from the <a href="http://scipy.org" target="_blank">scipy.org</a> website and downloaded and ran:<u></u><u></u></p>
<p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal">numpy-1.7.1-win32-superpack-python27.exe<u></u><u></u></p><p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal">This started up but I immediately saw the following dialog:<u></u><u></u></p>
<p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal">---------------------------<u></u><u></u></p><p class="MsoNormal">Cannot install<u></u><u></u></p><p class="MsoNormal">---------------------------<u></u><u></u></p>
<p class="MsoNormal">Python version 2.7 required, which was not found in the registry.<u></u><u></u></p><p class="MsoNormal">---------------------------<u></u><u></u></p><p class="MsoNormal">OK   <u></u><u></u></p><p class="MsoNormal">
---------------------------<u></u><u></u></p><p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal">The next dialog prompted for a Python installation to use but the list box was empty and it would not allow me to enter a path.<u></u><u></u></p>
<p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal">Is it absolutely necessary to build NumPy myself or is there a working installation out there? I know I'm doing something wrong but I don't know what it is. Any assistance would be greatly appreciated :).<u></u><u></u></p>
<p class="MsoNormal"><u></u> <u></u></p><p class="MsoNormal">Thanks,<u></u><u></u></p><p class="MsoNormal">Joseph A. Piccoli<u></u><u></u></p><p class="MsoNormal"><a href="mailto:joe13676@comcast.net" target="_blank">joe13676@comcast.net</a><u></u><u></u></p>
<p class="MsoNormal"><u></u> <u></u></p></div></div><br>_______________________________________________<br>
NumPy-Discussion mailing list<br>
<a href="mailto:NumPy-Discussion@scipy.org">NumPy-Discussion@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/numpy-discussion" target="_blank">http://mail.scipy.org/mailman/listinfo/numpy-discussion</a><br>
<br></blockquote></div><br>