<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div class=""><br></div></div></div></div>
</blockquote></div><br></div><div class="gmail_extra">OT:   Oh, I hate pip and packages that require numpy</div><div class="gmail_extra"><br></div><div class="gmail_extra"><div class="gmail_extra">E:\tmp>C:\Python27\python C:\Python27\Scripts\pip-script.py install -U patsy</div>
<div class="gmail_extra">Downloading/unpacking patsy</div><div class="gmail_extra">  Running setup.py (path:c:\users\josef\appdata\local\temp\pip_build_josef\patsy\setup.py) egg_info for package patsy</div><div class="gmail_extra">
<br></div><div class="gmail_extra">    no previously-included directories found matching 'doc\_build'</div><div class="gmail_extra">Downloading/unpacking numpy from <a href="https://pypi.python.org/packages/source/n/numpy/numpy-1.8.1.tar.gz#md5=be95babe263bfa3428363d6db5b64678">https://pypi.python.org/packages/source/n/numpy/numpy-1.8.1.tar.gz#md5=be95babe263bfa3428363d6db5b64678</a> (from patsy)</div>
<div class="gmail_extra">....</div><div class="gmail_extra"><br></div><div class="gmail_extra"><div class="gmail_extra">  Found existing installation: numpy 1.6.2</div><div class="gmail_extra">    Uninstalling numpy:</div>
<div class="gmail_extra">      Successfully uninstalled numpy</div><div class="gmail_extra">  Running setup.py install for numpy</div></div><div class="gmail_extra">...</div><div class="gmail_extra"><br></div><div class="gmail_extra">
...</div><div class="gmail_extra"><br></div><div class="gmail_extra"><div class="gmail_extra">C:\Python27\lib\distutils\dist.py:267: UserWarning: Unknown distribution option: 'define_macros'</div><div class="gmail_extra">
<br></div><div class="gmail_extra">  warnings.warn(msg)</div><div class="gmail_extra"><br></div><div class="gmail_extra">error: Unable to find vcvarsall.bat</div><div class="gmail_extra"><br></div><div class="gmail_extra">
----------------------------------------</div><div class="gmail_extra">  Rolling back uninstall of numpy</div><div class="gmail_extra">Cleaning up...</div><div class="gmail_extra"><br></div><div class="gmail_extra"><br></div>
<div class="gmail_extra">-------------------------</div><div class="gmail_extra">user error ?</div><div class="gmail_extra">I have a stale numpy-1.6.2-py2.7.egg-info file in site-packages</div><div class="gmail_extra"><br>
</div><div class="gmail_extra">put that's a nice new feature of pip   "Rolling back uninstall of numpy" </div><div class="gmail_extra">numpy is still here</div><div class="gmail_extra"><br></div><div class="gmail_extra">
Josef</div></div></div></div>