<div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote">On Tue, Aug 12, 2014 at 10:53 PM, Sturla Molden <span dir="ltr"><<a href="mailto:sturla.molden@gmail.com" target="_blank">sturla.molden@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div class="">Ralf Gommers <<a href="mailto:ralf.gommers@gmail.com">ralf.gommers@gmail.com</a>> wrote:<br>

<br>
> That's not possible. The only way you can do that is move the hard<br>
</div>> dependency on BLAS &amp; LAPACK to numpy, which we don't want to do.<br>
<br>
But NumPy already depends on BLAS and LAPACK, right?<br></blockquote><div><br></div><div>No. Numpy uses those libs when they're detected, but it falls back on its own dot implementation if they're not found. From first bullet under <a href="http://scipy.org/scipylib/building/linux.html#generic-instructions">http://scipy.org/scipylib/building/linux.html#generic-instructions</a>: "BLAS and LAPACK libraries (optional but strongly recommended for NumPy, required for SciPy)".<br>
<br></div><div>BLAS/LAPACK are heavy dependencies that often give problems, which is why you don't want to require them for the casual user that only needs numpy arrays to make some plots for examples.<br><br></div><div>
Ralf<br><br></div><div><br> <br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
<div class=""><div class="h5"><br>
_______________________________________________<br>
NumPy-Discussion mailing list<br>
<a href="mailto:NumPy-Discussion@scipy.org">NumPy-Discussion@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/numpy-discussion" target="_blank">http://mail.scipy.org/mailman/listinfo/numpy-discussion</a><br>
</div></div></blockquote></div><br></div></div>