<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Sun, Jun 21, 2015 at 5:13 PM, Charles R Harris <span dir="ltr"><<a href="mailto:charlesr.harris@gmail.com" target="_blank">charlesr.harris@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote"><span class="">On Sun, Jun 21, 2015 at 7:14 AM, Ralf Gommers <span dir="ltr"><<a href="mailto:ralf.gommers@gmail.com" target="_blank">ralf.gommers@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote"><span>On Fri, Jun 19, 2015 at 11:52 PM, Charles R Harris <span dir="ltr"><<a href="mailto:charlesr.harris@gmail.com" target="_blank">charlesr.harris@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote"><span>On Fri, Jun 19, 2015 at 3:05 PM, Sturla Molden <span dir="ltr"><<a href="mailto:sturla.molden@gmail.com" target="_blank">sturla.molden@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span>Charles R Harris <<a href="mailto:charlesr.harris@gmail.com" target="_blank">charlesr.harris@gmail.com</a>> wrote:<br>
<br>
> I'm looking to change some numpy deprecations into errors as well as remove<br>
> some deprecated functions. The problem I see is that<br>
> SciPy claims to support Numpy >= 1.5 and Numpy 1.5 is really, really, old.<br>
> So the question is, does "support" mean compiles with earlier versions<br>
> of Numpy ?<br>
<br>
</span>It means there is a Travis CI build with NumPy 1.6.2. So any change to the<br>
SciPy source code must compile with NumPy 1.6 and any later version of<br>
NumPy.<br>
<br>
There is no Travis CI build with NumPy 1.5. I don't think we know for sure<br>
if it is really compatible with the current SciPy.<br></blockquote></span></div></div></div></blockquote></span></div></div></div></blockquote><div><br></div></span><div>There is still a reference to 1.5 in Scipy, I forget where.<br></div></div></div></div></blockquote><div><br></div><div>In INSTALL.rst.txt, will fix that now.<br><br></div><div>Ralf<br> <br></div></div><br></div></div>