<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Dec 9, 2015 at 12:01 AM, Chris Barker <span dir="ltr"><<a href="mailto:chris.barker@noaa.gov" target="_blank">chris.barker@noaa.gov</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">drop 2.6<div><br></div><div>I still don't understand why folks insist that they need to run a (very)) old python on an old OS, but need the latest and greatest numpy.</div><div><br></div><div>Chuck's list was pretty long and compelling.</div><div><br></div><div>-CHB</div><div><br></div><div><br></div></div><div class="gmail_extra"><div><div class="h5"><br><div class="gmail_quote">On Mon, Dec 7, 2015 at 1:38 AM, Sturla Molden <span dir="ltr"><<a href="mailto:sturla.molden@gmail.com" target="_blank">sturla.molden@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span>Charles R Harris <<a href="mailto:charlesr.harris@gmail.com" target="_blank">charlesr.harris@gmail.com</a>> wrote:<br>
<br>
</span><span>> As a strawman proposal, how about dropping moving to 2.7 and 3.4 minimum<br>
> supported version next fall, say around numpy 1.12 or 1.13 depending on how<br>
> the releases go.<br>
><br>
> I would like to here from the scipy folks first.<br></span></blockquote></div></div></div></div></blockquote><div><br></div><div>+1 for dropping Python 2.6, 3.2 and 3.3 after branching 1.11.x. We're already behind other projects like ipython, pandas and matplotlib as usual, so there really isn't much point in being the only project (together with scipy) of the core stack to keep on supporting more or less obsolete Python versions. <br><br></div><div>Ralf<br><br></div><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="gmail_extra"><div><div class="h5"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span>
<br>
</span>Personally I would be in favor of this, because 2.7 and 3.4 are the minimum<br>
versions anyone should consider to use. However, for SciPy which heavily<br>
depends on Python code, the real improvement will be when we can bump the<br>
minimum Python version to 3.5 and write x @ y instead of dot(x,y). I am not<br>
sure of bumping the minimum version to 3.4 before that is worth it or not.<br>
But certainly dropping 2.6 might be a good thing already now, so we can<br>
start to use bytes, bytearray, memoryview, etc.<br>
<span><font color="#888888"><br>
Sturla<br>
</font></span><div><div><br>
_______________________________________________<br>
NumPy-Discussion mailing list<br>
<a href="mailto:NumPy-Discussion@scipy.org" target="_blank">NumPy-Discussion@scipy.org</a><br>
<a href="https://mail.scipy.org/mailman/listinfo/numpy-discussion" rel="noreferrer" target="_blank">https://mail.scipy.org/mailman/listinfo/numpy-discussion</a><br>
</div></div></blockquote></div><br><br clear="all"><div><br></div></div></div><span class="HOEnZb"><font color="#888888">-- <br><div><br>Christopher Barker, Ph.D.<br>Oceanographer<br><br>Emergency Response Division<br>NOAA/NOS/OR&R            <a href="tel:%28206%29%20526-6959" value="+12065266959" target="_blank">(206) 526-6959</a>   voice<br>7600 Sand Point Way NE   <a href="tel:%28206%29%20526-6329" value="+12065266329" target="_blank">(206) 526-6329</a>   fax<br>Seattle, WA  98115       <a href="tel:%28206%29%20526-6317" value="+12065266317" target="_blank">(206) 526-6317</a>   main reception<br><br><a href="mailto:Chris.Barker@noaa.gov" target="_blank">Chris.Barker@noaa.gov</a></div>
</font></span></div>
<br>_______________________________________________<br>
NumPy-Discussion mailing list<br>
<a href="mailto:NumPy-Discussion@scipy.org">NumPy-Discussion@scipy.org</a><br>
<a href="https://mail.scipy.org/mailman/listinfo/numpy-discussion" rel="noreferrer" target="_blank">https://mail.scipy.org/mailman/listinfo/numpy-discussion</a><br>
<br></blockquote></div><br></div></div>