<html xmlns="http://www.w3.org/1999/xhtml"><head> <title></title> <meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no"> </head> <body style="font-family:Helvetica;color:#000000;font-size:13px;"><div id="CanaryBody"> <div> Hi Mbeng!</div><div><br></div><div>What is the output of python --version and python3 --version? It seems to me that you’re still using Python 2.7.</div><div><br></div><div>You may need to use the command python3 rather than python.</div> <div><br></div> </div> <div id="CanarySig"> <div> <div style="font-family:Helvetica;color:#000;font-size:13px;">Best Regards,<div>Hameer Abbasi</div></div> <div><br></div> </div> </div> <div id="CanaryDropbox"> </div> <blockquote id="CanaryBlockquote"> <div> <div>On Tuesday, Apr 02, 2019 at 10:34 AM, Mbeng Tanyi <<a href="mailto:valentinatessy@gmail.com">valentinatessy@gmail.com</a>> wrote:<br></div> <div><div dir="ltr"><div dir="ltr"><div dir="ltr"><div>Hello</div><div><br></div><div>I still have a problem with this. I am using sphinx1.8.5 and changed the default python version on my computer to be 3.6 but I get the following error on<span style="background-color:rgb(238,238,238)"> $ make html </span>;<span style="background-color:rgb(238,238,238)"><br></span></div><div><span style="background-color:rgb(238,238,238)"><br></span></div><div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><span style="background-color:rgb(238,238,238)">Traceback (most recent call last):</span><br><span style="background-color:rgb(238,238,238)">  File "/home/valentina-t/.local/bin/sphinx-build", line 7, in <module></span><br><span style="background-color:rgb(238,238,238)">    from sphinx.cmd.build import main</span><br><span style="background-color:rgb(238,238,238)">  File "/home/valentina-t/.local/lib/python2.7/site-packages/sphinx/cmd/build.py", line 39</span><br><span style="background-color:rgb(238,238,238)">    file=stderr)</span><br><span style="background-color:rgb(238,238,238)">        ^</span><br><span style="background-color:rgb(238,238,238)">SyntaxError: invalid syntax</span><br><span style="background-color:rgb(238,238,238)">Makefile:123: recipe for target 'html' failed</span><br><span style="background-color:rgb(238,238,238)">make: *** [html] Error 1</span></blockquote><div> </div><div>I googled the error but didn't find anything really useful. I feel it has something to do with python2.7 as part of the path. Suppose I am right, I need help changing it to python3.6 please.</div><div><br></div><div>Regards</div><div>Mbeng Tanyi<br></div><span style="background-color:rgb(238,238,238)"><br></span><span style="background-color:rgb(238,238,238)"></span><span style="background-color:rgb(238,238,238)"></span></div><div><span style="background-color:rgb(238,238,238)"></span><br></div></div></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sun, Mar 31, 2019 at 9:20 PM Matti Picus <<a href="mailto:matti.picus@gmail.com">matti.picus@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><br> On 31/3/19 10:56 pm, Mbeng Tanyi wrote:<br> > Hello<br> ><br> > I also got an error the first time I tried $ make file as follows:<br> ><br> >     mkdir -p build/html build/doctrees<br> >     LANG=C sphinx-build -b html -WT --keep-going -d build/doctrees<br> >     source build/html<br> >     /bin/sh: 1: sphinx-build: not found<br> >     Makefile:123: recipe for target 'html' failed<br> >     make: *** [html] Error 127<br> ><br> ><br> > After upgrading to sphinx2 as was suggested here, I still get errors <br> > after $ make html :<br> ><br> >     mkdir -p build/html build/doctrees<br> >     LANG=C sphinx-build -b html -WT --keep-going -d build/doctrees  <br> >     source build/html<br> >     Traceback (most recent call last):<br> >       File "/home/valentina-t/.local/bin/sphinx-build", line 7, in<br> >     <module><br> >         from sphinx.cmd.build import main<br> >       File<br> >     "/home/valentina-t/.local/lib/python2.7/site-packages/sphinx/cmd/build.py",<br> >     line 39<br> >         file=stderr)<br> >             ^<br> >     SyntaxError: invalid syntax<br> >     Makefile:123: recipe for target 'html' failed<br> >     make: *** [html] Error<br> ><br> ><br> ><br> ><br> <br> You need to use sphinx version 1.8.5, and python3.6.<br> <br> Matti<br> <br> </blockquote></div> _______________________________________________ <br>NumPy-Discussion mailing list <br>NumPy-Discussion@python.org <br>https://mail.python.org/mailman/listinfo/numpy-discussion <br></div> </div> </blockquote> <img id="428EC9635D2BF11888F9B7126D464398" width="1px" src="http://pixels.canarymail.io:8100/track/977C99C0645380AF45E168B4CDA443F5_428EC9635D2BF11888F9B7126D464398.png" height="1px"></body></html>