<div dir="ltr"><div>Hi all,</div><div><br></div><div>We now have a guide for downstream package authors, talking about API and ABI stability, NumPy versioning, testing against NumPy master, and how to add build time and runtime dependencies for numpy: <a href="https://numpy.org/devdocs/user/depending_on_numpy.html">https://numpy.org/devdocs/user/depending_on_numpy.html</a></div><div><br></div><div>Especially the version constraints and setting upper bounds for install_requires correctly is important - almost no packages do this correctly (or at all really). If your package depends on NumPy and you deal with packaging it, please check it out! <br></div><div><br></div><div>And for even more practical details on release process steps for a downstream package, see <a href="http://scipy.github.io/devdocs/dev/core-dev/index.html#updating-upper-bounds-of-dependencies">http://scipy.github.io/devdocs/dev/core-dev/index.html#updating-upper-bounds-of-dependencies</a></div><div><br></div><div>Cheers,<br></div><div>Ralf</div><div><br></div></div>