[Patches] [ python-Patches-1244861 ] Enable os.startfile and webbrowser.WindowsDefault on Cygwin

SourceForge.net noreply at sourceforge.net
Thu Sep 15 15:04:09 CEST 2005


Patches item #1244861, was opened at 2005-07-26 01:38
Message generated for change (Comment added) made by birkenfeld
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=305470&aid=1244861&group_id=5470

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Modules
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Michael Hoffman (hoffmanm)
>Assigned to: Raymond Hettinger (rhettinger)
Summary: Enable os.startfile and webbrowser.WindowsDefault on Cygwin

Initial Comment:
This patch enables os.startfile() on Cygwin, converting
Cygwin POSIX paths to Windows paths unless they look
like URLs, and calling ShellExecute() on the result. It
also enables the webbrowser.WindowsDefault class, which
uses os.startfile(). It has to make WindowsError and
the PyErr*Windows* functions available as well because
win32_startfile() might call them.

----------------------------------------------------------------------

>Comment By: Reinhold Birkenfeld (birkenfeld)
Date: 2005-09-15 15:04

Message:
Logged In: YES 
user_id=1188172

Raymond, can you look at this one? It seems to be okay, but
I can't test it.

----------------------------------------------------------------------

Comment By: Michael Hoffman (hoffmanm)
Date: 2005-09-15 14:44

Message:
Logged In: YES 
user_id=987664

Let's try this again...

----------------------------------------------------------------------

Comment By: Reinhold Birkenfeld (birkenfeld)
Date: 2005-09-15 14:39

Message:
Logged In: YES 
user_id=1188172

I still see no patch... are you sure you check the right
box? ;-)

----------------------------------------------------------------------

Comment By: Michael Hoffman (hoffmanm)
Date: 2005-09-15 12:49

Message:
Logged In: YES 
user_id=987664

Argh, sorry about that. Thanks Reinhold; here's the patch.

----------------------------------------------------------------------

Comment By: Reinhold Birkenfeld (birkenfeld)
Date: 2005-09-15 09:20

Message:
Logged In: YES 
user_id=1188172

There's no uploaded file!  You have to check the
checkbox labeled "Check to Upload & Attach File"
when you upload a file. In addition, even if you
*did* check this checkbox, a bug in SourceForge
prevents attaching a file when *creating* an issue.

Please try again.

(This is a SourceForge annoyance that we can do
nothing about. :-( )

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=305470&aid=1244861&group_id=5470


More information about the Patches mailing list