[Patches] [ python-Patches-1570119 ] distutils - python 2.5 vc8 - non working setup

SourceForge.net noreply at sourceforge.net
Wed Oct 4 09:41:30 CEST 2006


Patches item #1570119, was opened at 2006-10-03 19:22
Message generated for change (Comment added) made by makaron
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=305470&aid=1570119&group_id=5470

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Windows
Group: Python 2.5
Status: Closed
Resolution: Rejected
Priority: 5
Submitted By: Grzegorz Makarewicz (makaron)
Assigned to: Nobody/Anonymous (nobody)
Summary: distutils - python 2.5 vc8 - non working setup

Initial Comment:
msvc prior to 8.0 have used .net sdk 1.1 as topelevel
version (7.0 - 1.0, 1.1 - 1.1 sp3) - msvc 8.0 uses 2.0
- this mall change makes it's still usefull - wxwidgets
goes without problems


----------------------------------------------------------------------

>Comment By: Grzegorz Makarewicz (makaron)
Date: 2006-10-04 09:41

Message:
Logged In: YES 
user_id=115179

C:\>python
Python 2.5 (release25-maint, Sep 21 2006, 10:06:38) [MSC
v.1400 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more
information.

I have recompiled python with visual studio 2005 - so it's a
msvc 8.0 and get_build_version returns 8.0


----------------------------------------------------------------------

Comment By: Martin v. Löwis (loewis)
Date: 2006-10-04 08:20

Message:
Logged In: YES 
user_id=21627

This patch is wrong. It should use these macros only if
get_build_version returns a version >=8.0.

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=305470&aid=1570119&group_id=5470


More information about the Patches mailing list