<div dir="ltr">Hi,<div><br></div><div>I'm having trouble installing pydotorg locally on my personal macbook.</div><div>Wondering if anyone will be able to help with this? Not sure if this is the right place to ask. I can also create a ticket in github if that's preferred.</div><div><br></div><div>Anyway, I'm following the instructions for Manual Setup, as described in this page: <a href="https://pythondotorg.readthedocs.io/install.html">https://pythondotorg.readthedocs.io/install.html</a></div><div><br></div><div>my steps:</div><div><br></div><div>







<p class=""><span class="">git clone git://<a href="http://github.com/python/pythondotorg.git">github.com/python/pythondotorg.git</a></span></p><p class=""><span class="">







</span></p><p class=""><span class="">cd pythondotorg</span></p><p class=""><span class="">python3.4 -m venv venv</span></p><p class=""><span class="">







</span></p><p class=""><span class="">pip install -r dev-requirements.txt</span></p><p class="">After this point, I see an error.</p><p class="">Here is a snippet:</p><p class="">







</p><p class=""><span class="">Requirement already satisfied (use --upgrade to upgrade): oauthlib>=0.6.2 in /usr/local/lib/python3.4/site-packages (from requests-oauthlib>=0.3.0->django-allauth==0.22.0->-r requirements.txt (line 40))</span></p><p class=""><span class="">Installing collected packages: uWSGI</span></p><p class=""><span class="">  Running setup.py install for uWSGI ... error</span></p><p class=""><span class="">    Complete output from command /usr/local/opt/python3/bin/python3.4 -u -c "import setuptools, tokenize;__file__='/private/var/folders/8t/szq9prv16rn3dvdjcd_q6cym0000gs/T/pip-build-0hp0c9ai/uWSGI/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /var/folders/8t/szq9prv16rn3dvdjcd_q6cym0000gs/T/pip-fjrw0gqx-record/install-record.txt --single-version-externally-managed --compile:</span></p><p class=""><span class="">    running install</span></p><p class="">











</p><p class=""><span class="">    using profile: buildconf/default.ini</span></p><p class="">.. some really long message or stack trace of some sort... and then:</p><p class=""><span class="">*** uWSGI compiling server core ***</span></p><p class=""><span class="">    [thread 1][clang] core/utils.o</span></p><p class=""><span class="">    [thread 2][clang] core/protocol.o</span></p><p class=""><span class="">    [thread 0][clang] core/socket.o</span></p><p class=""><span class="">    [thread 3][clang] core/logging.o</span></p><p class=""><span class="">    [thread 1][clang] core/master.o</span></p><p class=""><span class="">    [thread 2][clang] core/master_utils.o</span></p><p class=""><span class="">    core/socket.c:713:28: error: use of undeclared identifier 'SOL_TCP'</span></p><p class=""><span class="">                    if (setsockopt(serverfd, SOL_TCP, TCP_FASTOPEN, (const void *) &uwsgi.tcp_fast_open, sizeof(int)) < 0) {</span></p><p class=""><span class="">                                             ^</span></p><p class=""><span class="">    1 error generated.</span></p><p class="">


















</p><p class=""><span class="">    </span>Command "/usr/local/opt/python3/bin/python3.4 -u -c "import setuptools, tokenize;__file__='/private/var/folders/8t/szq9prv16rn3dvdjcd_q6cym0000gs/T/pip-build-0hp0c9ai/uWSGI/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /var/folders/8t/szq9prv16rn3dvdjcd_q6cym0000gs/T/pip-fjrw0gqx-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/var/folders/8t/szq9prv16rn3dvdjcd_q6cym0000gs/T/pip-build-0hp0c9ai/uWSGI/</p>







<p class="">Does anyone have any ideas of what's going on? Is there a problem with my machine perhaps? I'm using Macbook OS X El Capitan 10.11.6 if that matters.</p><p class="">Thanks. I would really appreciate any help with this.</p></div><div><br></div><div><br></div><div><div><div class="gmail_signature" data-smartmail="gmail_signature">Mariatta Wijaya</div></div>
</div></div>