[pypy-svn] r54667 - pypy/dist/pypy/config

xoraxax at codespeak.net xoraxax at codespeak.net
Mon May 12 12:25:51 CEST 2008


Author: xoraxax
Date: Mon May 12 12:25:49 2008
New Revision: 54667

Modified:
   pypy/dist/pypy/config/pypyoption.py
Log:
Reorder the del working_modules and add a question.

Modified: pypy/dist/pypy/config/pypyoption.py
==============================================================================
--- pypy/dist/pypy/config/pypyoption.py	(original)
+++ pypy/dist/pypy/config/pypyoption.py	Mon May 12 12:25:49 2008
@@ -30,17 +30,22 @@
 ))
 
 if sys.platform == "win32":
-    del working_modules["_socket"] # MLS - Added 5/11/08 - broken
+    # unix only modules
+    del working_modules["crypt"]
+    del working_modules["fcntl"]
+    del working_modules["termios"]
+    del working_modules["_minimal_curses"]
+    # modules currently missing explicit windows support
+    del working_modules["signal"]
+    del working_modules["_rawffi"]
+    # modules with broken windows support
     del working_modules["mmap"]    # MLS - Added 5/11/08 - broken
-    del working_modules["fcntl"]   # UNIX only
+    del working_modules["_socket"] # MLS - Added 5/11/08 - broken
     del working_modules["select"] # MLS - Added 5/11/08 - broken
-    del working_modules["crypt"] # broken
-    del working_modules["signal"] # UNIX Only
+    # modules with unknown windows support
+    # XXX what exactly is broken here? are the libs installed on the buildbots?
     del working_modules["zlib"] # MLS - Added 5/11/08 - broken
-    del working_modules["_rawffi"]
-    del working_modules["termios"]# UNIX Only
-    del working_modules["bz2"]# UNKNOWN State - needs validating
-    del working_modules["_minimal_curses"] #UNIX Only
+    del working_modules["bz2"]  # UNKNOWN State - needs validating
 
 
 



More information about the Pypy-commit mailing list