[pypy-svn] r64670 - pypy/branch/pyjitpl5/pypy/jit/backend/test

arigo at codespeak.net arigo at codespeak.net
Sat Apr 25 14:05:25 CEST 2009


Author: arigo
Date: Sat Apr 25 14:05:23 2009
New Revision: 64670

Modified:
   pypy/branch/pyjitpl5/pypy/jit/backend/test/test_random.py
Log:
Rename GuardBinaryOperation to GuardOperation
(they are not binary at all).


Modified: pypy/branch/pyjitpl5/pypy/jit/backend/test/test_random.py
==============================================================================
--- pypy/branch/pyjitpl5/pypy/jit/backend/test/test_random.py	(original)
+++ pypy/branch/pyjitpl5/pypy/jit/backend/test/test_random.py	Sat Apr 25 14:05:23 2009
@@ -111,7 +111,7 @@
             v_second = v
         self.put(builder, [v_first, v_second])
 
-class GuardBinaryOperation(AbstractOperation):
+class GuardOperation(AbstractOperation):
 
     def produce_into(self, builder, r):
         v = builder.get_bool_var(r)
@@ -158,8 +158,9 @@
 OPERATIONS.append(BinaryOperation(rop.INT_RSHIFT, LONG_BIT-1))
 OPERATIONS.append(BinaryOperation(rop.INT_LSHIFT, LONG_BIT-1))
 OPERATIONS.append(BinaryOperation(rop.UINT_RSHIFT, LONG_BIT-1))
-OPERATIONS.append(GuardBinaryOperation(rop.GUARD_TRUE))
-OPERATIONS.append(GuardBinaryOperation(rop.GUARD_FALSE))
+
+OPERATIONS.append(GuardOperation(rop.GUARD_TRUE))
+OPERATIONS.append(GuardOperation(rop.GUARD_FALSE))
 
 for _op in [rop.INT_NEG,
             rop.INT_INVERT,



More information about the Pypy-commit mailing list