[pypy-commit] pypy default: Make unwrap_specs a bit more readable.

alex_gaynor noreply at buildbot.pypy.org
Sun Jun 19 20:27:48 CEST 2011


Author: Alex Gaynor <alex.gaynor at gmail.com>
Branch: 
Changeset: r45025:a74dec87ff48
Date: 2011-06-19 11:31 -0700
http://bitbucket.org/pypy/pypy/changeset/a74dec87ff48/

Log:	Make unwrap_specs a bit more readable.

diff --git a/pypy/module/pypyjit/interp_resop.py b/pypy/module/pypyjit/interp_resop.py
--- a/pypy/module/pypyjit/interp_resop.py
+++ b/pypy/module/pypyjit/interp_resop.py
@@ -10,17 +10,16 @@
 class W_DebugMergePoint(Wrappable):
     """ A class representing debug_merge_point JIT operation
     """
-    
+
     def __init__(self, mp_no, offset, pycode):
         self.mp_no = mp_no
         self.offset = offset
         self.pycode = pycode
 
-    @unwrap_spec('self', ObjSpace)
     def descr_repr(self, space):
         return space.wrap('DebugMergePoint()')
 
- at unwrap_spec(ObjSpace, W_Root, int, int, PyCode)
+ at unwrap_spec(mp_no=int, offset=int, pycode=PyCode)
 def new_debug_merge_point(space, w_tp, mp_no, offset, pycode):
     return W_DebugMergePoint(mp_no, offset, pycode)
 
@@ -39,4 +38,3 @@
     __repr__ = interp2app(W_DebugMergePoint.descr_repr),
     code = interp_attrproperty('pycode', W_DebugMergePoint),
 )
-


More information about the pypy-commit mailing list