[pypy-commit] pypy default: (arigo, bivab): do not require gcc 4.0 as a default on the mac anymore

bivab noreply at buildbot.pypy.org
Tue Nov 29 12:58:39 CET 2011


Author: David Schneider <david.schneider at picle.org>
Branch: 
Changeset: r49952:e68a7b79ae93
Date: 2011-11-29 12:57 +0100
http://bitbucket.org/pypy/pypy/changeset/e68a7b79ae93/

Log:	(arigo, bivab): do not require gcc 4.0 as a default on the mac
	anymore

diff --git a/pypy/translator/platform/darwin.py b/pypy/translator/platform/darwin.py
--- a/pypy/translator/platform/darwin.py
+++ b/pypy/translator/platform/darwin.py
@@ -12,17 +12,10 @@
 
     so_ext = 'dylib'
 
-    # NOTE: GCC 4.2 will fail at runtime due to subtle issues, possibly
-    # related to GC roots. Using LLVM-GCC or Clang will break the build.
-    default_cc = 'gcc-4.0'
-
-    def __init__(self, cc=None):
-        if cc is None:
-            try:
-                cc = os.environ['CC']
-            except KeyError:
-                cc = self.default_cc
-        self.cc = cc
+    # NOTE: With asmgcc GCC 4.2 will fail at runtime due to subtle issues,
+    # possibly related to GC roots. Using LLVM-GCC or Clang will break the
+    # build. On Darwin asmgcc is not the default anymore, so it is fine to use
+    # whatever gcc we find on the system
 
     def _args_for_shared(self, args):
         return (list(self.shared_only)


More information about the pypy-commit mailing list