[pypy-commit] pypy better-jit-hooks: review notes

alex_gaynor noreply at buildbot.pypy.org
Sat Jan 7 21:21:32 CET 2012

Author: Alex Gaynor <alex.gaynor at gmail.com>
Branch: better-jit-hooks
Changeset: r51125:1c83e7759323
Date: 2012-01-07 14:21 -0600

Log:	review notes

diff --git a/REVIEW.rst b/REVIEW.rst
new file mode 100644
--- /dev/null
+++ b/REVIEW.rst
@@ -0,0 +1,12 @@
+* ``namespace=locals()``, can we please not use ``locals()``, even in tests?  I find it super hard to read, and it's bad for the JIT.
+* Don't we already have a thing named portal (portal call maybe?) is the name confusing?
+* ``interp_reso.pyp:wrap_greenkey()`` should do something useful on non-pypyjit jds.
+* The ``WrappedOp`` constructor doesn't make much sense, it can only create an op with integer args?
+* Let's at least expose ``name`` on ``WrappedOp``.
+* DebugMergePoints don't appears to get their metadata.
+* Someone else should review the annotator magic.
+* Are entry_bridge's compiled seperately anymore? (``set_compile_hook`` docstring)

More information about the pypy-commit mailing list