[pypy-commit] pypy ppc-updated-backend: Rename _teardown to teardown

ISF noreply at buildbot.pypy.org
Thu May 22 23:37:38 CEST 2014


Author: Ivan Sichmann Freitas <ivansichfreitas at gmail.com>
Branch: ppc-updated-backend
Changeset: r71678:31b0dfd8cca9
Date: 2014-05-22 21:34 +0000
http://bitbucket.org/pypy/pypy/changeset/31b0dfd8cca9/

Log:	Rename _teardown to teardown

	Consistent with the other backends

diff --git a/rpython/jit/backend/ppc/ppc_assembler.py b/rpython/jit/backend/ppc/ppc_assembler.py
--- a/rpython/jit/backend/ppc/ppc_assembler.py
+++ b/rpython/jit/backend/ppc/ppc_assembler.py
@@ -855,7 +855,7 @@
                     'loop.asm')
 
         ops_offset = self.mc.ops_offset
-        self._teardown()
+        self.teardown()
 
         debug_start("jit-backend-addr")
         debug_print("Loop %d (%s) has address %x to %x (bootstrap %x)" % (
@@ -925,7 +925,7 @@
         self._patch_sp_offset(sp_patch_location, rawstart)
 
         ops_offset = self.mc.ops_offset
-        self._teardown()
+        self.teardown()
 
         debug_start("jit-backend-addr")
         debug_print("bridge out of Guard %d has address %x to %x" %
@@ -1009,7 +1009,7 @@
             size += 1
         return size
 
-    def _teardown(self):
+    def teardown(self):
         self.patch_list = None
         self.pending_guards = None
         self.current_clt = None


More information about the pypy-commit mailing list