[pypy-dev] Error on translation?

Jiwon Seo seojiwon at gmail.com
Tue May 2 07:33:47 CEST 2006

Hi all,

I am trying to run translated versions of targetnopstandalone.py,
targetrpystonedalone.py (and eventually pypy-c) on a simulator.
However, even before that, the translated versions on real machine
(so, not on a simulator) crash.  (Machine spec and options for
translate.py are at the end)

For instance, translated version of targetrpystonedalone.py produces
segmentation fault when I ran it.  The stack when segfault occurs
looks like following:

_RPyListOfString_SetItem(list, i, s) in main.h

pypy_list0 *l_l_1, long l_index_0, struct pypy_rpy_string0
*l_newstring_0) in implement.c

pypy_list0 *l_l_2, long l_index_1, struct pypy_rpy_string0
*l_newitem_2) in implement.c

and inside the last function, segmentation fault occurs at
 l_v10 = l_l_2->l_items;

because l_l_2 is not allocated. (actually, I don't see any place that
l_l_2 is allocated before that line)

I'm runnint the translated executable on ppc linux:
(uname -a shows following: Linux rundmc.stanford.edu 2.6.15-1.2054_FC5
#1 SMP Tue Mar 14 15:57:06 EST 2006 ppc64 ppc64 ppc64 GNU/Linux)

and I ran translate.py with --text --no-compile --source --gc=ref
options, and then mv /tmp/usession-x/testing_1/ to a new place, then
compiled it. Ah, and I'm using current version of pypy.

Any idea?


More information about the Pypy-dev mailing list