[pypy-dev] llvm backend issue on AMD64

Jacob Hallén jacob at strakt.com
Thu Nov 30 15:38:48 CET 2006

On Thursday 30 November 2006 13:29, Alexandre Fayolle wrote:
> On Thu, Nov 30, 2006 at 12:42:48PM +0100, Eric van Riet Paap wrote:
> > Hi Alexandre,
> >
> > Thank you for trying this out!
> >
> > Do the llvm tests pass?
> Unfortunately, no. See http://codespeak.net/~afayolle/summary.html for
> details.
> The installed llvm version is 1.8b. llvm-gcc --version says
> llvm-gcc (GCC) 3.4-llvm 20051104 (LLVM 1.7cvs)
> > pypy-llvm has not been properly tested on 64 bit systems! Some
> > efforts were made but compatibilty was never maintained because of a
> > lack of such a machine.
> > If you could give me an account on your computer I could make sure
> > that at least proper checks are in place.
> I am afraid this is going to be difficult. The machine is inside
> logilab's LAN, and only available through a VPN. However I'll be happy
> to help solving the issue (trying to patch the code if pointed in some
> initial direction, or applying patches and reporting back)

I have an amd64 machine running a pure 64 bit debian system (etch). I can make 
an account available.


More information about the Pypy-dev mailing list