[pypy-dev] pypy-c and JIT

Lenard Lindstrom len-l at telus.net
Sun Oct 21 19:01:39 CEST 2007

My guess is the pypy-c considers the current directory as its root 
directory. This differs from Cpython which uses a registry entry.

Raj Bandyopadhyay wrote:
> Hi Armin
> It only worked for me when I cd'ed to the pypy-1.0.0 directory and  
> ran pypy-c there.
> When I added pypy-1.0.0 to my path and ran pypy-c from somewhere  
> else, it gave me errors saying that some modules are not found. This  
> could definitely be a result of my inexperience with windows, but if  
> you get a chance, please do test it out.
> Thanks!
> Raj
> On Oct 21, 2007, at 5:53 AM, Armin Rigo wrote:
>> Hi Raj,
>> On Tue, Oct 16, 2007 at 11:30:56AM -0500, Raj wrote:
>>> Well, for my previous problem, pypy-c on windows worked only when  
>>> I ran
>>> it in the installation directory, so I did copped out and ran my  
>>> programs
>>> by copying them over. Didn't really find a proper solution to the  
>>> problem,
>>> but I assume it involves setting some path variables.
>> I'm confused.  I tried downloading the file pypy-1.0.0-win32.zip and
>> looked around (didn't test it on Windows myself though).  The zip
>> contains all the necessary standard library .py files, and I think  
>> that
>> the paths you get in the zip are correct.  In other words, if you run
> _______________________________________________
> pypy-dev at codespeak.net
> http://codespeak.net/mailman/listinfo/pypy-dev

Lenard Lindstrom
<len-l at telus.net>

More information about the Pypy-dev mailing list