[pypy-dev] Compiling RSDL and ExternalCompilationInfo

Leonardo Santagada santagada at gmail.com
Wed Mar 4 02:38:40 CET 2009


I've tried running some RSDL examples in my computer and they are not  
working, but if I try to compile the code by hand it works (without  
the framework and includes it does complain the same as translation on  
pypy):

Apfelstrudel:~/projects/pypy/pypy/rlib/rsdl/macosx-sdl-main santagada$  
gcc -I/Library/Frameworks/SDL.framework/Headers -framework Cocoa - 
framework SDL SDLMain.m
Undefined symbols:
   "_SDL_main", referenced from:
       -[SDLMain applicationDidFinishLaunching:] in ccCdkKBZ.o
ld: symbol(s) not found
collect2: ld returned 1 exit status

The error is because the supporting code does not have a main (I  
think). But when I try to translate something with pypy I get this  
other error on this paste http://paste.pocoo.org/show/106398/ wich  
ends with:

pypy.translator.platform.CompilationError: <CompilationError  
err='Undefined symbols:\n  "_CPSEnableForegroundOperation", referenced  
from:\n      _CustomApplicationMain in cckWdEVi.o\n...erenced from: 
\n      _NSApp$non_lazy_ptr in cckWdEVi.o\nld: symbol(s) not found 
\ncollect2: ld returned 1 exit status\n'>
Apfelstrudel:~/projects/pypy/pypy/rlib/rsdl santagada$

Using py.test to run the example it stops saying I don't have sdl  
installed (the error defined on the check_sdl_installation in eci.py.

The eci.py file should be defining it but besides Version/A/Headers  
(which I also tried changing on my WC) appears to be trying to define  
what I typed to gcc. What could be going on?

--
Leonardo Santagada
santagada at gmail.com






More information about the Pypy-dev mailing list