[pypy-dev] unable to translate with current head of default

wlavrijsen at lbl.gov wlavrijsen at lbl.gov
Wed May 25 15:43:14 CEST 2011

Hi Anto,

> Not sure to understand: do you get a crash even now that you merged default?

yes, that's the case.

> If this is the case, do you get it even with a trunk version of pypy? You
> don't have to translate it by yourself, you can just download one of the
> nightly builds:
> http://buildbot.pypy.org/nightly/trunk/

With pypy-c-jit-44414-19bf70a7d70c-linux.tar.bz2, I get no crash. Could it
be as silly as having a buggy gcc or other tool used underneath when building?
My local gcc is 4.4.1, whereas the above pypy build is 4.4.3.

> ./pypy-c --jit enable_opts=intbounds:rewrite:virtualize:string:heap:ffi:unroll
> the line above is equivalent of a plain pypy-c, because it enables all
> optimizations.  Try to remove some of them and see if you still get the crash.

Okay, that sounds like something I can try, but it'll take a bit to run through
some of the possible combinations.

WLavrijsen at lbl.gov    --    +1 (510) 486 6411    --    www.lavrijsen.net

More information about the pypy-dev mailing list