[pypy-dev] question re: ancient SSL requirement of pypy

David Malcolm dmalcolm at redhat.com
Tue Feb 21 17:16:04 CET 2012

On Mon, 2012-02-13 at 14:42 -0800, Dale Hubler wrote:
> Hello,
> I was requested to install pypy but our computers appear to be too new 
> to run it, having libssl.so.0.9.8e among other newer items.   This 
> confuses me because the web page for pypy shows a 2011 date and blog 
> entries from 2012.   Can 2005 SSL really be a requirement, I am unable 
> to install such an old item on a cluster where this software might be used.
> I looked at the pypy site but cannot find any supported platforms, 
> install guide, etc.   I am trying this on RedHat EL 5.   I tried the 
> binary release, but it also had the same error, no libssl.so.0.9.8, 
> which is true, my systems are updated.  I must be missing something.   
> Do you have any links or other on-line info explaining how to build pypy.  

FWIW, I've built PyPy 1.8 in RPM form for RHEL 5 and 6, within the
"EPEL" community repositories:  http://fedoraproject.org/wiki/EPEL

So if you've configured the EPEL repos, you can install pypy via:

  # yum install pypy

and not have to do the translation yourself.

Note that this is a side-project by me, not an "official" Red
Hat-supported thing.

The EPEL 5 builds of pypy 1.8 can be seen here:

The EPEL 6 builds of pypy 1.8 can be seen here:

Hope this is helpful

More information about the pypy-dev mailing list