[pypy-dev] pypy translation failures

Robert Grosse n210241048576 at gmail.com
Fri Jul 6 07:07:27 CEST 2012


Hello, I am having difficulties translating Pypy, but googling searching
did not reveal any mentions of similar problems, so I am not sure what to
do.

I am not able to successfully translate Pypy, using any combination of
options I have tried. Here are my results so far.

Ubuntu 12.04 64 bit
Trying to translate pypy sandbox from latest source release (I can find the
actual hash number if necessary).
I used PYPY_GC_MAX_DELTA=200MB and loop_longevity=300 as suggested to
reduce memory usage, along with -O2 and --sandbox
The translator produced an executable, but attempting to run this
executable with or without pypy_interact.py leads to an immediate
termination with the message
Fatalerror during initialization out of memory

Windows 7 64 bit
Same steps as above except without max delta, and using the 1.9 source
release.
The sandbox again fails with the Fatalerror out of memory. It also produces
some weird characters before terminating which I'm guessing are the
marshalled stdout from the sandbox.

Windows 7 64 bit
Attempt to translate plain Pypy, with -Ojit but no loop longevity.
Translation fails partway through with a MemoryError despite several GB of
free memory.

I have tried both CPython 2.7 and prebuilt Pypy binaries to do the
translating, and nothing I do will work. I can't find any mentions of
others experiencing similar problems, but the fact that the problems show
up for me with multiple versions on multiple machines with different OSs
indicates that something serious is wrong. Does anyone have any idea what
the problem might be?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/pypy-dev/attachments/20120706/2c24d1de/attachment-0001.html>


More information about the pypy-dev mailing list