[pypy-dev] Compiling for pypy

Jan Riechers janpeterr at freenet.de
Fri Jul 20 12:53:22 CEST 2012

On 20.07.2012 13:34, Amaury Forgeot d'Arc wrote:
> 2012/7/20 Jan Riechers <janpeterr at freenet.de>:
>> yes, I assume I use the most recent version 1.9, but official windows build,
>> not a own compilation. I saw there was already a similiar issue posted here
>> (for reference, my error below):
>> http://www.mail-archive.com/pypy-dev@python.org/msg02117.html
> And the answer was:
> http://www.mail-archive.com/pypy-dev@python.org/msg02119.html
> Does PIL compiles with CPython on your system?

On 20.07.2012 11:36, Maciej Fijalkowski wrote:
 > On Fri, Jul 20, 2012 at 10:11 AM, Jan Riechers <janpeterr at freenet.de
 > <mailto:janpeterr at freenet.de>> wrote:
 >     On 19.07.2012 23:10, Raymond Roberts wrote:
 >         Have you tried building the pymongo driver without the C 
 >     Hello Raymond
 >     thank you for coming back, I just tried once more and the pymongo
 >     driver works. Also the latest version.
 >     I caused some trouble by having also greenlet and eventlet
 >     installed, seems that those did not like to come along and 
causing the:
 >     "Fatal Python error: PyThreadState_Get: no current thread" error
 >     Actually I also use pil besides eventlet and greenlet, but this time
 >     I can't get pil compiled correctly and raises me a compiler error
 >     during start of the c module compilation. But this is another topic
 >     I guess plus I haven't searched for any answer yet.
 >     But if you have any information in matter of the above modules - PIL
 >     is assumed to work with Pypy it states in the wiki, please let me 
 >     Thank you in advance,
 >     Jan
 > Indeed, PIL should work, what's the error? Are you using recent PyPy?
 > Cheers,
 > fijal

Sorry for posting twice on this PIL issue, but perhaps I should use 
"Pillow" as proposed here:

I just tried the latest branch from github at:

and it works

But PIL is definetly broken it seems, its also on python Package index 
and also on the gitHub notes.

Thank you Fijal for helping out, hope this message reachs you before 
digging too much.



For some reason my message did not appear, but I tried Pillow as noted 
above and also it run with the support libraries fine (jpeg, zlib).

Pil, as stated, does not compile with the errors noted earlier.


More information about the pypy-dev mailing list