[pypy-dev] Current status of GUI support in PyPy

Oscar Benjamin oscar.j.benjamin at gmail.com
Thu Dec 17 09:33:17 EST 2015


On 16 December 2015 at 14:43, Armin Rigo <arigo at tunes.org> wrote:
>
> On Wed, Dec 16, 2015 at 2:05 PM, Oscar Benjamin
> <oscar.j.benjamin at gmail.com> wrote:
>> libtcl8.5.so: cannot open shared object file: No such file or
>> directory
>>
>> Is that an obscure crash?
>
> Sadly not.  It just means it was compiled for libtcl8.5.so, and your
> machine has a different version installed.

I'm not sure about that:

enojb at it054759:~$ ls /usr/lib/libtcl*
/usr/lib/libtcl8.5.so.0
enojb at it054759:~$ ls /usr/lib/libtk*
/usr/lib/libtk8.5.so.0

Maybe it's just missing the symlink from libtcl8.5.so ->
libtcl8.5.so.0. I'm not sure why it would be setup like that.

> You can recompile it
> simply by running:
>
>     cd  /users/enojb/src/pypy-4.0.1-linux64/lib_pypy/_tkinter/
>     ../../bin/pypy  tklib_build.py

The above gave me an error about "tk.h" so I installed tk8.5-dev. I
recompiled tkinter and can now import Tkinter without error.

Afterwards I noticed that installing tk8.5-dev gave me this:

enojb at it054759:~$ ls /usr/lib/libtk*
/usr/lib/libtk8.5.a  /usr/lib/libtk8.5.so  /usr/lib/libtk8.5.so.0
/usr/lib/libtkstub8.5.a
enojb at it054759:~$ ls /usr/lib/libtcl*
/usr/lib/libtcl8.5.a  /usr/lib/libtcl8.5.so  /usr/lib/libtcl8.5.so.0
/usr/lib/libtclstub8.5.a

--
Oscar


More information about the pypy-dev mailing list