[pypy-dev] problems with pypy and pip

Amaury Forgeot d'Arc amauryfa at gmail.com
Wed Jul 8 11:20:02 CEST 2015


2015-07-07 19:20 GMT+02:00 Matti Picus <matti.picus at gmail.com>:

>  This is all documented in our FAQ
> http://pypy.readthedocs.org/en/latest/faq.html#do-cpython-extension-modules-work-with-pypy
>
> Some modules, like wxPython, that use the python c API or ctypes will
> either not work with PyPy or will be much slower than cPython. We highly
> recommend cffi as an alternative foreign function interface, since it is
> nicer than ctypes and is fast on PyPy, but it may be a while until module
> authors see the light of the one true way.
>

Old versions of wxPython ("classic") used SWIG to wrap the C++ libraries,
and could be compiled with PyPy. It worked, but it was a long time ago, was
the result was quite slow...
http://morepypy.blogspot.fr/2010/05/running-wxpython-on-top-of-pypy.html
(unfortunately the screenshots are lost)

Newer versions of wxPython ("Phoenix") use SIP to wrap the C++ libraries,
and there is no way it can be supported directly by PyPy (SIP uses
metaclasses with custom tp_alloc slots to subclass int... I tried).

There was an attempt to port have SIP file generate a cffi interface, it
did not go to completion but looks very promising.
There is a nice story here: http://waedt.blogspot.fr/
It seems that all basic infrastructure are there, but many widgets extend
SIP wrappers and use the C API: they need to be rewritten in a
cffi-friendly fashion.

Good luck with wxPython.


>
> The wiki page https://bitbucket.org/pypy/compatibility/wiki/Home may have
> some hints about module compatibility, note that your mileage may vary and
> updates are welcome.
>
> Also, you should be using visual studio 2008 (for both PyPy 2.6.0 and
> cPython 2.7), using this link should get you started
> https://www.microsoft.com/en-us/download/details.aspx?id=44266
> Matti
>
>
>
> On 05/07/15 07:44, germano carella wrote:
>
> Hi,
> I downloaded pypy 2.6.0 and I ran pypy -m ensurepip. All worked correctly.
> Now, in some cases, when i do pip install somepackage, it say could not
> find any download that satisfy requirements.
> This even if packages apear in pip search command.
> I tried wxPython, but i'm unable to install it...
> In other cases, pip says that windows ssdk is not found. But I have visual
> studio 2013 installed and windows sdk is on my pc.
> There are variables Can I set?
> Thanks!
> _______________________________________________
> pypy-dev mailing list
> pypy-dev at python.org
> https://mail.python.org/mailman/listinfo/pypy-dev
>
>
>
> _______________________________________________
> pypy-dev mailing list
> pypy-dev at python.org
> https://mail.python.org/mailman/listinfo/pypy-dev
>
>


-- 
Amaury Forgeot d'Arc
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/pypy-dev/attachments/20150708/32b84a5f/attachment-0001.html>


More information about the pypy-dev mailing list