[pypy-dev] Tensorflow build errors

Shuaib Osman vretiel at gmail.com
Mon Jan 13 10:46:35 EST 2020


Hi,

I'm trying to compile tensorflow r1.14 from source following the
instruction on the TF website.

Here's my setup:

pypy3 virtual environment with:
- Pypy3 (latest version 7.3) on ubuntu 18.04
- Cuda 10.1 installed
- numpy 1.18.1 installed

I've asked for XLA jit compilation and CUDA support from the ./configure
script

the build command:

bazel build --config=opt --config=cuda
//tensorflow/tools/pip_package:build_pip_package

compiles about 23000 targets and then fails with this stacktrace:

...

Traceback (most recent call last):
  File
"/home/vretiel/.cache/bazel/_bazel_vretiel/ec2591a0fe29386400d95468f7c519e5/execroot/org_tensorflow/bazel-out/host/bin/tensorflow/python/keras/api/create_tensorflow.python_api_1_keras_python_api_gen_compat_v1.runfiles/org_tensorflow/tensorflow/python/pywrap_tensorflow.py",
line 58, in <module>
    from tensorflow.python.pywrap_tensorflow_internal import *
  File
"/home/vretiel/.cache/bazel/_bazel_vretiel/ec2591a0fe29386400d95468f7c519e5/execroot/org_tensorflow/bazel-out/host/bin/tensorflow/python/keras/api/create_tensorflow.python_api_1_keras_python_api_gen_compat_v1.runfiles/org_tensorflow/tensorflow/python/pywrap_tensorflow_internal.py",
line 28, in <module>
    _pywrap_tensorflow_internal = swig_import_helper()
  File
"/home/vretiel/.cache/bazel/_bazel_vretiel/ec2591a0fe29386400d95468f7c519e5/execroot/org_tensorflow/bazel-out/host/bin/tensorflow/python/keras/api/create_tensorflow.python_api_1_keras_python_api_gen_compat_v1.runfiles/org_tensorflow/tensorflow/python/pywrap_tensorflow_internal.py",
line 20, in swig_import_helper
    import _pywrap_tensorflow_internal
ModuleNotFoundError: No module named '_pywrap_tensorflow_internal'

The exact same commands (./configure {with the same options} and bazel
build --config=opt --config=cuda
//tensorflow/tools/pip_package:build_pip_package) work perfectly when
compiling against cpython 3.6.
So there's some path/name mangling going on with pypy3.

Any idea how I can get this compilation to work?
Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/pypy-dev/attachments/20200113/b83e8357/attachment.html>


More information about the pypy-dev mailing list