[pypy-dev] Pypy on aarch64 (rhe7) has issues with bzip2-libs

Srinivasa Kempapura Padmanabha Srinivasa.KempapuraPadmanabha at arm.com
Thu Oct 8 07:43:30 EDT 2020


Hi,

Thank you so much for your response, I tried all methods including patchelf as well.  But it din't help, hence initiated mail thread. However, I will also find if there is something else missing on my env.

No, worries. Let me send you the complete details in sometime with snapshot but for now, please see the following

I have downloaded and symlinked the libbz2.so libraries in customized path and then append that path to LD_LIBRARY_PATH, followed by it launched pypy which even didnt run.

Please note, I am instlalling pypy in customized path.

# download and extract the pypy for arm arch.

Host: > pwd
/workspace/usr/workspace/pypy3.6-v7.2.0-aarch64/bin

# launch pypy, gives error
host> ./pypy3
./pypy3: error while loading shared libraries: libbz2.so.1.0: cannot open shared object file: No such file or directory
si-b6-24:srikem01 > ldd ./py
pypy3*       pypy3.debug
Host : > ldd ./pypy3
./pypy3: /lib64/libtinfo.so.5: no version information available (required by /workspace/usr /workspace/pypy3.6-v7.2.0-aarch64/bin/./libpypy3-c.so)
linux-vdso.so.1 =>  (0x0000ffff80270000)
libpypy3-c.so => /workspace/usr/workspace/pypy3.6-v7.2.0-aarch64/bin/./libpypy3-c.so (0x0000ffff7ce10000)
libc.so.6 => /lib/libc.so.6 (0x0000ffff7cc80000)
libutil.so.1 => /lib64/libutil.so.1 (0x0000ffff7cc20000)
libdl.so.2 => /lib64/libdl.so.2 (0x0000ffff7cbf0000)
libbz2.so.1.0 => not found
libexpat.so.1 => /lib64/libexpat.so.1 (0x0000ffff7cba0000)
libm.so.6 => /lib64/libm.so.6 (0x0000ffff7cae0000)
libz.so.1 => /lib64/libz.so.1 (0x0000ffff7caa0000)
libffi.so.6 => /lib64/libffi.so.6 (0x0000ffff7ca70000)
libtinfo.so.5 => /lib64/libtinfo.so.5 (0x0000ffff7ca20000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x0000ffff7c9e0000)
/lib/ld-linux-aarch64.so.1 (0x0000aaaab0830000)

# locate if I have libbz2 so
Host: > locate libbz2
/usr/lib64/libbz2.so
/usr/lib64/libbz2.so.1
/usr/lib64/libbz2.so.1.0.6

# ldd to libpypy
> ldd libpypy3-c.so
./libpypy3-c.so: /lib64/libtinfo.so.5: no version information available (required by ./libpypy3-c.so)
linux-vdso.so.1 =>  (0x0000ffffa6480000)
libutil.so.1 => /lib64/libutil.so.1 (0x0000ffffa2fe0000)
libdl.so.2 => /lib64/libdl.so.2 (0x0000ffffa2fb0000)
libbz2.so.1.0 => not found
libexpat.so.1 => /lib64/libexpat.so.1 (0x0000ffffa2f60000)
libm.so.6 => /lib64/libm.so.6 (0x0000ffffa2ea0000)
libz.so.1 => /lib64/libz.so.1 (0x0000ffffa2e60000)
libffi.so.6 => /lib64/libffi.so.6 (0x0000ffffa2e30000)
libtinfo.so.5 => /lib64/libtinfo.so.5 (0x0000ffffa2de0000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x0000ffffa2da0000)
libc.so.6 => /lib/libc.so.6 (0x0000ffffa2c10000)
/lib/ld-linux-aarch64.so.1 (0x0000aaaad4050000)

But libtinfo actually exists

> locate libtinfo.so.5
/usr/lib64/libtinfo.so.5
/usr/lib64/libtinfo.so.5.9

#Append the LD_LIBRARY_PATH to have /usr/lib64

host > setenv LD_LIBRARY_PATH /lib:/usr/lib:/usr/lib64
host > ls
libpypy3-c.so  libpypy3-c.so.debug  pypy3  pypy3.debug
host > ./libpypy3-c.so
Segmentation fault
host > ldd ./libpypy3-c.so
./libpypy3-c.so: /usr/lib64/libtinfo.so.5: no version information available (required by ./libpypy3-c.so)
linux-vdso.so.1 =>  (0x0000ffffa9050000)
libutil.so.1 => /usr/lib64/libutil.so.1 (0x0000ffffa5be0000)
libdl.so.2 => /usr/lib64/libdl.so.2 (0x0000ffffa5bb0000)
libbz2.so.1.0 => not found
libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x0000ffffa5b30000)
libm.so.6 => /usr/lib64/libm.so.6 (0x0000ffffa5a70000)
libz.so.1 => /usr/lib64/libz.so.1 (0x0000ffffa5a30000)
libffi.so.6 => /usr/lib64/libffi.so.6 (0x0000ffffa5a00000)
libtinfo.so.5 => /usr/lib64/libtinfo.so.5 (0x0000ffffa59b0000)
libpthread.so.0 => /usr/lib64/libpthread.so.0 (0x0000ffffa5970000)
libc.so.6 => /lib/libc.so.6 (0x0000ffffa57e0000)
/lib/ld-linux-aarch64.so.1 (0x0000aaaade890000)

host > ldd /usr/lib64/libtinfo.so.5
linux-vdso.so.1 =>  (0x0000ffffb1960000)
libc.so.6 => /lib/libc.so.6 (0x0000ffffb1770000)
/lib/ld-linux-aarch64.so.1 (0x0000aaaae5410000)

host > rpm -qf /usr/lib64/libtinfo.so.5
ncurses-libs-5.9-14.20130511.el7_4.aarch64
host >

Regards,
Srini


On 08/10/20, 4:16 PM, "Armin Rigo" <armin.rigo at gmail.com> wrote:

    Hi,

    On Thu, 8 Oct 2020 at 10:22, Srinivasa Kempapura Padmanabha
    <Srinivasa.KempapuraPadmanabha at arm.com> wrote:
    > I think it's looking for /usr/lib64/libbz2.so.1.0.0 which I am not sure if that's compatible

    It should be, if it differs only in the last digit.

    > I have created the symbolic link and yet idn't work

    Sorry, I can't help you more.  Maybe if you described with more
    details what "didn't work"?  What are you running and what error
    message are you getting?


    Armin

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.


More information about the pypy-dev mailing list