[PyPy-issue] [issue642] 64bit sandboxes with jit fail during startup

Janno pypy-dev-issue at codespeak.net
Fri Feb 25 01:36:40 CET 2011


Janno <mail at janno-kaiser.de> added the comment:

I see your point. My use case does may not require any security guarantees, just
some disincentive for tampering. A pypy sandbox with the JIT seems to be a
perfect fit since it's at least twice as fast cpython.

I tried again (42255:17bd126d3fee) without JIT and I'm still unable to start the
sandbox:
/usr/src/pypy/pypy/translator/sandbox/pypy_interact.py pypy-c
[sandlib:call] ll_os.ll_os_getenv('PYPY_GENERATIONGC_NURSERY')
[sandlib:result] None
[sandlib:call] ll_os.ll_os_open('/proc/cpuinfo', 0L, 420L)
[sandlib:exception] OSError: [Errno 2] proc
Warning: cannot find your CPU L2 cache size in /proc/cpuinfo
[sandlib:call] ll_os.ll_os_getenv('PYPY_GC_DEBUG')
[sandlib:result] None
Not Implemented: sandboxing for external function 'pypysig_getaddr_occurred'
Invalid RPython operation (NULL ptr or bad array index)
[Subprocess killed by SIGIOT]

The only unusual error that I get from all those revisions is:
[platform:Error] /usr/bin/ld: cannot find -lintl
[platform:Error] collect2: ld returned 1 exit status

I don't know if my working jit sandbox generated the same error during
translation but I recall seeing it a few times during my more recent
translations (newer revision).

I've attached the build log just in case I'm missing something important.

_______________________________________________________
PyPy development tracker <pypy-dev-issue at codespeak.net>
<https://codespeak.net/issue/pypy-dev/issue642>
_______________________________________________________
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: buildlog.txt
URL: <http://mail.python.org/pipermail/pypy-issue/attachments/20110225/13abf455/attachment.txt>


More information about the Pypy-issue mailing list