[pypy-issue] [issue790] SSL and bz2 lib paths are broken on RHEL 5

jayqhacker tracker at bugs.pypy.org
Tue Jul 12 16:39:50 CEST 2011


New submission from jayqhacker <jayqhacker at gmail.com>:

PyPy 1.5 can't find some of it's shared libraries on RedHat 5.  PyPy seems to be
looking for two "significant digits" in the version number, whereas RedHat
provides one and three.

PyPy wants:

libssl.so.0.9.8
libcrypto.so.0.9.8
libbz2.so.1.0

RedHat 5.5 provides:

/lib64/libssl.so.6
/lib64/libssl.so.0.9.8e
/lib64/libcrypto.so.6
/lib64/libcrypto.so.0.9.8e
/usr/lib64/libbz2.so
/usr/lib64/libbz2.so.1
/usr/lib64/libbbz2.so.1.0.3

It would be nice if PyPy ran out of the box on RedHat 5.

----------
messages: 2787
nosy: jayqhacker, pypy-issue
priority: bug
release: 1.5
status: unread
title: SSL and bz2 lib paths are broken on RHEL 5

________________________________________
PyPy bug tracker <tracker at bugs.pypy.org>
<https://bugs.pypy.org/issue790>
________________________________________


More information about the pypy-issue mailing list