[pypy-issue] [issue885] Lack of libffi5 on Ubuntu 11.10 stops PyPy running

anon tracker at bugs.pypy.org
Wed Sep 28 04:14:40 CEST 2011


New submission from anon <b10419697 at klzlk.com>:

On Ubuntu 11.10 (Beta 2) when I try to run PyPy 1.6 or an in-development PyPy
build I get the following error:

error while loading shared libraries libffi.so.5: cannot open shared object
file: No such file or directory

PyPy runs happily on Ubuntu 11.04 however. The problem seems to be that Ubuntu
11.10 provides the newer version of the library as libffi.so.6 (corresponding to
the package libffi6 on Ubuntu 11.10) while PyPy links to libffi.so.5
(corresponding to the package libffi5 on Ubuntu 11.04).

Please ask if there's any further information I can provide.

----------
messages: 3202
nosy: anon, pypy-issue
priority: bug
status: unread
title: Lack of libffi5 on Ubuntu 11.10 stops PyPy running

________________________________________
PyPy bug tracker <tracker at bugs.pypy.org>
<https://bugs.pypy.org/issue885>
________________________________________


More information about the pypy-issue mailing list