[pypy-issue] [issue934] subprocess hangs in 1.7 (but not in 1.6 or 1.5)

mikefc tracker at bugs.pypy.org
Mon Jan 9 08:38:49 CET 2012


mikefc <coolbutuseless at gmail.com> added the comment:

I'm running on latest OSX nightly and it does not hang, but I do get a 'build failed' error.


======================================
~/pypy-latest/bin/pypy ./waf configure clean build -p -j5
Setting top to                           : /Users/mike/python/bug934/build 
Setting out to                           : /Users/mike/python/bug934/build/out 
Checking for program g++,c++             : /usr/bin/g++ 
Checking for program ar                  : /usr/bin/ar 
Waf: Entering directory `/Users/mike/python/bug934/build/out'
Fatal error: pthread_cond_signal(&cond_gil)                                                                                  ]
[0.968s]
Fatal error: pthread_cond_signal(&cond_gil)                                                                                  ]
[1.594s]
[79/79][100%][\][===========================================================================================================>]
[2.603s]
Waf: Leaving directory `/Users/mike/python/bug934/build/out'
Build failed
 -> task failed (exit status -6): 
	{task 4354190936: cxx class_56.cpp -> class_56.cpp.1.o}
['/usr/bin/g++', '-I/Users/mike/python/bug934/build/out', '-I/Users/mike/python/bug934/build', '../lib_0/class_56.cpp', '-c', '-
o', 'lib_0/class_56.cpp.1.o']
 -> task failed (exit status -6): 
	{task 4354188808: cxx class_18.cpp -> class_18.cpp.1.o}
['/usr/bin/g++', '-I/Users/mike/python/bug934/build/out', '-I/Users/mike/python/bug934/build', '../lib_0/class_18.cpp', '-c', '-
o', 'lib_0/class_18.cpp.1.o']

----------
nosy: +mikefc
status: unread -> chatting

________________________________________
PyPy bug tracker <tracker at bugs.pypy.org>
<https://bugs.pypy.org/issue934>
________________________________________


More information about the pypy-issue mailing list