[pypy-issue] [issue1249] Itertools.tee not working correctly with pypy?

David tracker at bugs.pypy.org
Sat Sep 1 17:51:54 CEST 2012


New submission from David <davidhalter88 at gmail.com>:

Hi! I'm the developer of Jedi: https://github.com/davidhalter/jedi, which is an 
auto-completion library. I try to support Python 2.5-3.2. Out of curiosity, I 
tried to use PyPy, which worked incredibly well! But:
Some tests just won't work sometimes with PyPy.

# for i in $(seq 10); do pypy test/run.py goto 92; done

sometimes works, and sometimes doesn't. It seems like, itertools.tee sometimes 
returns old values. PyPy seems working perfectly fine, if I use iter(list()) 
arround all the itertools.tee objects. (I'm speaking about the iterator on 
jedi/evaluate.py:1338).

Is there something that I'm missing?

Tests of Python 2.5-3.2 are passing:
http://travis-ci.org/#!/davidhalter/jedi

Cheers!
David

----------
messages: 4691
nosy: David, pypy-issue
priority: bug
release: 1.8
status: chatting
title: Itertools.tee not working correctly with pypy?

________________________________________
PyPy bug tracker <tracker at bugs.pypy.org>
<https://bugs.pypy.org/issue1249>
________________________________________


More information about the pypy-issue mailing list