[pypy-issue] [issue1359] SEGFAULT when running Scrapy tests.

Joe Hillenbrand tracker at bugs.pypy.org
Thu Jan 3 17:41:13 CET 2013


New submission from Joe Hillenbrand <joehillen at gmail.com>:

This happens with the latest 2.0beta1 release and the current tip of the hg repo
(29b8abf6816b)

To reproduce, run:

$ git clone git://github.com/scrapy/scrapy.git
$ cd scrapy
$ /opt/pypy-dev/bin/pypy setup.py install
$ /opt/pypy-dev/bin/trial scrapy/tests/test_http_request.py
scrapy.tests.test_http_request
  FormRequestTest
    test_ajax_url ...                                                      [OK]
    test_body ...                                                          [OK]
    test_copy ...                                                          [OK]
    test_copy_inherited_classes ...                                        [OK]
    test_custom_encoding ...                                               [OK]
    test_default_encoding ...                                              [OK]
    test_empty_formdata ...                                                [OK]
    test_eq ...                                                            [OK]
    test_from_response_ambiguous_clickdata ... Segmentation fault (core dumped)

----------
messages: 5121
nosy: joehillen, pypy-issue
priority: bug
release: 2.0
status: unread
title: SEGFAULT when running Scrapy tests.

________________________________________
PyPy bug tracker <tracker at bugs.pypy.org>
<https://bugs.pypy.org/issue1359>
________________________________________


More information about the pypy-issue mailing list