[pypy-issue] Issue #2070: unable to build matplotlib with pypy 2.6.0 (pypy/pypy)

Sam McDermott issues-reply at bitbucket.org
Wed Jun 24 20:02:39 CEST 2015


New issue 2070: unable to build matplotlib with pypy 2.6.0
https://bitbucket.org/pypy/pypy/issue/2070/unable-to-build-matplotlib-with-pypy-260

Sam McDermott:

First of all, I'm new to PyPy, but I am intrigued by the performance reports; I'm repeatedly multiplying lots of big arrays right now, and CPython has seemed to hit a wall that PyPy could have some native advantages with. A factor of few speedup is really appealing.

To get started, I need a few python modules that are available on pip, but I've had trouble getting them to install correctly with PyPy. The problem appears to trace back to issues with matplotlib installation. When installing from source, I get

```
#!bash

In file included from src/ft2font_wrapper.cpp:3:
src/file_compat.h:7:10: fatal error: 'numpy/ndarrayobject.h' file not found
#include "numpy/ndarrayobject.h"
         ^
1 error generated.
In file included from src/ft2font_wrapper.cpp:3:
```

Then another similar error is generated, followed by "failed with exit status 1."

I haven't seen anything too recent regarding matplotlib on the website, but if there are any known bugs or fixes, they would be most welcome! (I am listing this as a minor bug since I'm new here, but maybe it is bigger or smaller than that!)

Thanks for any help,
Sam




More information about the pypy-issue mailing list