[pypy-issue] Issue #2283: Import error relating to __pycache__ (pypy/pypy)

Henry issues-reply at bitbucket.org
Sun Apr 24 11:04:07 EDT 2016


New issue 2283: Import error relating to __pycache__
https://bitbucket.org/pypy/pypy/issues/2283/import-error-relating-to-__pycache__

Henry:

Volatility 2.5 (www.volatilityfoundation.org) is a digital forensics tools. I built and installed it with no problem, but when I ran it, there were many import errors. Copy __init__.py into __pycache__ will solve this problem, but it's better that pypy can handle this case.

Errors:
$ vol.py
Volatility Foundation Volatility Framework 2.5
*** Failed to import volatility.plugins.mac.__pycache__.bash_env.pypy-41 (ImportError: No module named volatility.plugins.mac.__pycache__)
*** Failed to import volatility.plugins.mac.__pycache__.check_sysctl.pypy-41 (ImportError: No module named volatility.plugins.mac.__pycache__)
*** Failed to import volatility.plugins.mac.__pycache__.dlyd_maps.pypy-41 (ImportError: No module named volatility.plugins.mac.__pycache__)
*** Failed to import volatility.plugins.mac.__pycache__.list_files.pypy-41 (ImportError: No module named volatility.plugins.mac.__pycache__)
*** Failed to import volatility.plugins.mac.__pycache__.common.pypy-41 (ImportError: No module named volatility.plugins.mac.__pycache__)
*** Failed to import volatility.plugins.mac.__pycache__.list_kauth_scopes.pypy-41 (ImportError: No module named volatility.plugins.mac.__pycache__)
*** Failed to import volatility.plugins.mac.__pycache__.print_boot_cmdline.pypy-41 (ImportError: No module named volatility.plugins.mac.__pycache__)
*** Failed to import volatility.plugins.mac.__pycache__.apihooks.pypy-41 (ImportError: No module named volatility.plugins.mac.__pycache__)
...




More information about the pypy-issue mailing list