[pypy-issue] Issue #2358: pip install matplotlib fails on PyPy 5.3 on OS X (pypy/pypy)

Josiah Walker issues-reply at bitbucket.org
Sun Jul 31 16:54:40 EDT 2016


New issue 2358: pip install matplotlib fails on PyPy 5.3 on OS X
https://bitbucket.org/pypy/pypy/issues/2358/pip-install-matplotlib-fails-on-pypy-53-on

Josiah Walker:

Numpy is installed from the main numpy repository (the fix for pypy has already been added to it). Scipy has installed successfully. Installing matplotlib gives the following error:

UPDATING build/lib.macosx-10.11-x86_64-2.7/matplotlib/_version.py
    set build/lib.macosx-10.11-x86_64-2.7/matplotlib/_version.py to '1.5.1'
    running build_ext
    building 'matplotlib.ft2font' extension
    Traceback (most recent call last):
      File "<module>", line 1, in <module>
      File "/private/var/folders/fx/1bjz7pr54fj20zcwdkmhbl480000gn/T/pip-build-e5DbXy/matplotlib/setup.py", line 277, in <module>
        **extra_args
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/core.py", line 151, in setup
        dist.run_commands()
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/dist.py", line 953, in run_commands
        self.run_command(cmd)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/dist.py", line 972, in run_command
        cmd_obj.run()
      File "/usr/local/Cellar/pypy/5.3.0/libexec/site-packages/setuptools/command/install.py", line 61, in run
        return orig.install.run(self)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/command/install.py", line 573, in run
        self.run_command('build')
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/cmd.py", line 334, in run_command
        self.distribution.run_command(command)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/dist.py", line 972, in run_command
        cmd_obj.run()
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/command/build.py", line 127, in run
        self.run_command(cmd_name)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/cmd.py", line 334, in run_command
        self.distribution.run_command(command)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/dist.py", line 972, in run_command
        cmd_obj.run()
      File "/usr/local/Cellar/pypy/5.3.0/libexec/site-packages/setuptools/command/build_ext.py", line 68, in run
        _build_ext.run(self)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/command/build_ext.py", line 347, in run
        self.build_extensions()
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/command/build_ext.py", line 456, in build_extensions
        self.build_extension(ext)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/site-packages/setuptools/command/build_ext.py", line 180, in build_extension
        _build_ext.build_extension(self, ext)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/lib-python/2.7/distutils/command/build_ext.py", line 503, in build_extension
        include_dirs=ext.include_dirs,
      File "setupext.py", line 785, in __get__
        result = obj._hooks[self._name]() + result
      File "setupext.py", line 812, in include_dirs_hook
        reload(numpy)
      File "/usr/local/Cellar/pypy/5.3.0/libexec/site-packages/numpy/__init__.py", line 117, in <module>
        raise RuntimeError('Reloading numpy is not supported')
    RuntimeError: Reloading numpy is not supported
    
    ----------------------------------------
Command "/usr/local/Cellar/pypy/5.3.0/bin/pypy -u -c "import setuptools, tokenize;__file__='/private/var/folders/fx/1bjz7pr54fj20zcwdkmhbl480000gn/T/pip-build-e5DbXy/matplotlib/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /var/folders/fx/1bjz7pr54fj20zcwdkmhbl480000gn/T/pip-p_3Kp6-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/var/folders/fx/1bjz7pr54fj20zcwdkmhbl480000gn/T/pip-build-e5DbXy/matplotlib/





More information about the pypy-issue mailing list