[pypy-issue] Issue #2318: JIT requires recent Z-Arch (pypy/pypy)

Stefano Rivera issues-reply at bitbucket.org
Thu Jun 9 03:58:44 EDT 2016


New issue 2318: JIT requires recent Z-Arch
https://bitbucket.org/pypy/pypy/issues/2318/jit-requires-recent-z-arch

Stefano Rivera:

Debian supports all z-arch subarchitectures, and pypy used to do so, before the zarch JIT was added. Now we get SIGILL on our z990 buildd

https://buildd.debian.org/status/fetch.php?pkg=pypy&arch=s390x&ver=5.3%2Bdfsg-1&stamp=1465458240

If the JIT requires modern zarch, can it disable itself if it detects an older CPU, rather than crashing with SIGILL?

Responsible: plan_rich


More information about the pypy-issue mailing list