[pypy-issue] Issue #2327: Unable to install matplotlib with pypy 5.3.0 on MacOS X (GCC 4.2.1) (pypy/pypy)

Jared Hoag issues-reply at bitbucket.org
Mon Jun 13 18:26:40 EDT 2016


New issue 2327: Unable to install matplotlib with pypy 5.3.0 on MacOS X (GCC 4.2.1)
https://bitbucket.org/pypy/pypy/issues/2327/unable-to-install-matplotlib-with-pypy-530

Jared Hoag:

The key part is the following:


```
#!bash

 cc -arch x86_64 -O2 -fPIC -Wimplicit -DPY_ARRAY_UNIQUE_SYMBOL=MPL_matplotlib_backends__macosx_ARRAY_API -DNPY_NO_DEPRECATED_API=NPY_1_7_API_VERSION -I/opt/pypy2-v5.3.0-osx64/site-packages/numpy-1.12.0.dev0+d69c147-py2.7-macosx-10.11-x86_64.egg/numpy/core/include -I/usr/local/include -I/usr/X11/include -I/opt/X11/include -I. -Iextern/agg24-svn/include -I/opt/pypy2-v5.3.0-osx64/include -c src/_macosx.m -o build/temp.macosx-10.11-x86_64-2.7/src/_macosx.o
    src/_macosx.m:3743:17: warning: null passed to a callee that requires a non-null argument [-Wnonnull]
        data = [rep representationUsingType:filetype properties:nil];
                    ^                                           ~~~
    src/_macosx.m:5167:51: warning: incompatible pointer types passing 'unichar *' (aka 'unsigned short *') to parameter of type 'const wchar_t *' (aka 'const int *') [-Wincompatible-pointer-types]
            PyObject* string =  PyUnicode_FromUnicode(buffer, n);
                                                      ^~~~~~
    /opt/pypy2-v5.3.0-osx64/include/pypy_decl.h:905:63: note: passing argument to parameter 'arg0' here
    PyAPI_FUNC(PyObject *) PyPyUnicode_FromUnicode(const wchar_t *arg0, Py_ssize_t arg1);
                                                                  ^
    src/_macosx.m:6384:5: error: use of undeclared identifier 'PyOS_InputHook'
        PyOS_InputHook = wait_for_stdin;
        ^
    2 warnings and 1 error generated.
    error: command 'cc' failed with exit status 1
    
    ----------------------------------------
Command "/usr/local/bin/pypy -u -c "import setuptools, tokenize;__file__='/private/var/folders/lm/km4ftqs548z3k7z9_b5plpzc0000gn/T/pip-build-0iGov6/matplotlib/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /var/folders/lm/km4ftqs548z3k7z9_b5plpzc0000gn/T/pip-Tx4Jcu-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/var/folders/lm/km4ftqs548z3k7z9_b5plpzc0000gn/T/pip-build-0iGov6/matplotlib/
```

I have created a pastebin at: http://pastebin.com/ZN0HVTzq showing the full log of trying to install matplotlib for/with pypy 5.3.0.




More information about the pypy-issue mailing list